Anyone that have a Puma innova

Anyone that have a Puma innova

Joined: November 2nd, 2005, 10:12 pm

February 17th, 2011, 9:24 am #1

Hi guys. I have a problem with my Innova cloone.
Reply
Share

Joined: June 2nd, 2009, 12:39 pm

February 17th, 2011, 5:17 pm #2

I've got one. Haven't had any problems with mine.
Reply
Share

Joined: November 2nd, 2005, 10:12 pm

February 17th, 2011, 6:47 pm #3

Hi.When i pump the first stroke, i can hear the air leaking throu the barrel. Sometimes even the second stroke leak. It sounds like the valve isnt closed.I did look at a shematic on the gun, and it looks like it has a hammer and hammer spring, just as a Crosman 1377. But i wonder, you dont have to cock the gun, just pump and fire. Do you know how the trigger and valve system is built?
Last edited by 500cc on February 17th, 2011, 6:54 pm, edited 1 time in total.
Reply
Share

Joined: May 28th, 2007, 10:10 pm

February 18th, 2011, 3:36 am #4

You may have to chronograph it to see if it is shooting to specifications.
Reply
Share

Joined: November 2nd, 2005, 10:12 pm

February 18th, 2011, 4:13 am #5

Yes i can do that,but it dont feels right, as sometimes even the second stroke leaks air. I am thinking to take the valve apart, and put in some harder spring to close the valve harder. Thanks Tommy.
Reply
Share

Joined: June 2nd, 2009, 12:39 pm

February 18th, 2011, 4:06 pm #6

I've got one. Haven't had any problems with mine.
you could try changing the spring but first look to see if there's a relief hole drilled in the face of the valve. If so, you can tap it and insert a grub screw or see if you can get that half of the valve or a whole assy from TW Chambers. The Puma isn't set-up like a Crosman 1377 different kind of system. If air is leaking from the barrel then perhaps your right and it's the spring. You could also contact Paul Self of Raineair, he may have some advice on what to do.
Reply
Share

Joined: November 2nd, 2005, 10:12 pm

February 18th, 2011, 5:36 pm #7

Ok. Thanks. Its not so fun, the gun is brand new, and its so fun to shoot with.I did take it apart and put in a little lomger spring, but it leak more. Shall take it apart tonigt and put in a shorter spring and se.Its a verry strange kind of valve system. Not as the Daisy 880 either Thanks Tommy.
Last edited by 500cc on February 18th, 2011, 5:38 pm, edited 1 time in total.
Reply
Share

Joined: March 28th, 2002, 6:54 pm

February 18th, 2011, 7:10 pm #8

Hi guys. I have a problem with my Innova cloone.
If the gun won't seal on the first pump or two, it's likely the valve face is out of square to the valve stem(sharp ACE type), or the lubes are too stiff (sharp Inova, crosman 1400 style)
Reply
Share

Joined: November 2nd, 2005, 10:12 pm

February 18th, 2011, 8:01 pm #9

Ok. I did take the valve out of the tube, but i think it was loctited so i didnt take it apart. But i have to take it apart to fix this, or? I have thinking about how the valve opens when i pull the trigger? Cause there is no hammer.
Reply
Share

Joined: March 28th, 2002, 6:54 pm

February 18th, 2011, 10:15 pm #10

or of an exploded diagram(maybe one came with the gun?)

You could also look at the crosman diagrams, and see if the 140 or 1400 valves look like what you have.
Last edited by classicalgas on February 18th, 2011, 10:16 pm, edited 1 time in total.
Reply
Share