Plugin Installation Common Issues and Solutions

Plugin Installation Common Issues and Solutions

Joined: August 24th, 2015, 11:16 am

April 11th, 2018, 8:47 am #1

In this section, we provide answers and solutions to the most common issues with the Tapatalk Plugin.  
Please take a look and see if this can solve your issue. If you still cannot find a solution, please submit a support ticket.



Incorrect API key or missing API key

The newest version of the Plugins automatically set and update the Tapatalk API key.  The easiest solution to fix this issue is to update your plugin.
The other option is to manually update the API key in your Admin CP.

The issue is that either 1) the API Key is missing in your forum Admin Control Panel > Tapatalk options; or, 2)  the API in your Admin CP does not match with the API key in your Tapatalk Dashboard.

To correct this, Log In to Site Owner Console, then go to Site Settings. Scroll down to just below your forum logo/cover photo and you will find the API key.  Copy the Tapatalk API Key.

Go to your Forum Admin CP > Tapatalk Options and paste the API Key into the Admin CP.  (In some Admin CPs the API Key maybe be called “Push Notification Key.”)


Incorrect file permissions for mobiquo directory

Please check the file permissions and owner for forumroot/index.php. Set the same for mobiquo directory. Please ensure you set the file permissions for mobiquo directory, recursive subdirectories AND files contained within ALL to the same (not just the mobiquo folder itself).


Plugin installed but not activated

In some forum systems, the plugin has to be manually activated in your Admin CP>Tapatalk Options. If you are receiving this error message, login to your Admin CP>Plugin options and activate the Tapatalk Plugin.
Please note that if you have your forum set as “under maintenance” mode, the plugin will return as inactive.


Hook file version does not match plugin file version

During plugin installation, when you are required to upload the mobiquo folder to your site and install the xml file in your forum admin dashboard, if the version ID of the files do not match, the plugin will automatically appear as inactive.

To solve this issue, you need to ensure both mobiquo folder and xml file are installed correctly and both are from the same plugin package version.

Plugin expired (or too old)

For best user experience, you should update your plugin to the latest version. Also make sure your forum system and php versions of your servers are up-to-date.

We always test our plugins to be fully compatible with the latest version of forum systems. By making sure the Tapatalk Plugin is up to date, you and your members will have the best user experience.  And an update to date plugin will also take care of most technical issues.

Please note that before you submit a Support Ticket, we do require an up to date plugin. (And in most cases, the update will solve your technical issue)


Connection problem for SSO and Push

In the plugins released since June 2016, we built in a new plugin status page. You can see an example below.

You can access it pointing your browser to http://yourforum.com/mobiquo/status.php. To access this file, you must be logged in as admin in your forum system.
In the status you’ll see all information/status about your Tapatalk plugin. For the best user experience, all status checks on this page should be green.


API Key Mismatch/Not installed Error

Having the incorrect API key entered will prevent certain Tapatalk features like push notifications and SSO from working.

To correct this issue:
  1. Please log into your forum owner account on Tapatalk.com and view your published forum’s dashboard
  2. Copy the Tapatalk API key listed for your forum
  3. Verify and input the correct Tapatalk API key into your forum’s
  4. Tapatalk options panel located within your forum’s admin control panel.
Q: I’ve followed these instructions, and the API key installation status still shows an error. What’s causing this?
A: Please check to see if your API key has any typos or if you cut and paste it exactly from our console, please make sure you did not include an extra space at the end of your entered API key.

Q: I cannot find where in my forum’s Admin Control Panel (AdminCP) to enter the API key. Where do I find it?
A: The location will depend on your forum system, please visit this link and select your forum platform. After installation of the Tapatalk plug-in, a Tapatalk specific preferences section will be available in your forum’s AdminCP, the field to enter your API key will be located there.

Q: Will my forum function without the API key? What’s the advantage of installing it?
A: Advanced features like push notifications and SSO will not work but your forum will be available on Tapatalk. The advantage of enabling all of Tapatalk’s advanced functions is that it makes it easier for users to join and sign-into your forum (SSO) and keeps them coming back when things they care about occur on your forum via push notifications. These tools help maintain a high level of engagement.

Miscellaneous Plug In Issues

In the plugins released since June 2016, we built in a new plugin status page. You can see an example below.

You can access it pointing your browser to http://yourforum.com/mobiquo/status.php. To access this file, you must be logged in as admin in your forum system.
In the status you’ll see all information/status about your Tapatalk plugin. For the best user experience, all status checks on this page should be green.

Pasted_Image_9_1_16__6_19_PM.jpg

If you see a problem in the Connectivity to Tapatalk Servers panel, check the following:
  • That you have Curl installed
  • That your firewall does not block access to
   directory.tapatalk.com
   push.tapatalk.com
   Tapatalk.com
   verifiy.tapatalk.com
   and search.tapatalk.com.



Here is an example of what the plugin info page looks like if one of the above servers the mentioned servers are blocked by your firewall.


Pasted_Image_9_1_16__6_24_PM.jpg


Required PHP functions unavailable

Please ensure your php supports:
  • Json_encode, Json_decode (extension=json.so in your php.ini)
  • cUrl
Issue with php 5.6 and http_raw_post_data

You’ll need to configure php.ini correctly and set the param httpraw in php.ini. This is a one time change.

Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version.
To avoid this warning set ‘always_populate_raw_post_data’ to ‘-1’ in php.ini and use the php://input stream instead.

(In the Tapatalk plugin code, the deprecated function has already been removed. However, there is a problem with php 5.6 that is creating the issue.  For more information please refer to the StackOverFlow article and/or the Reddit entry below).

StackOverFlow Reference  

Reddit Reference
Like
Share