PHP Deprecated, issue with php 5.6?

User avatar
audisport_ch
6
Joined: October 8th, 2013, 4:29 pm

April 13th, 2016, 9:24 pm

Hi guys,

Sorry, our host has increased php version to 5.6. Since that, we have everything working fine but I have a lot of errors in server logs related to php deprecated in relation to mobiquo.

Is that possible to assist us?

PHP message: PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0

Thanks a lot for your assistance :)

User avatar
Howdy
Joined: May 11th, 2015, 3:49 am

April 14th, 2016, 8:08 am

As indicated by the php error, pls. configure php.ini correctly and set the param httpraw in php.ini.


Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version.

To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini

and use the php://input stream instead.


This is only one time change. In Tapatalk plugin code, the deprecated function has already been removed, is a problem with php 5.6 that is causing the issue as it raises that deprecated issue despite the function appears or not when there is a POST request. More info can be found here: http://stackoverflow.com/questions/2626 ... deprecated and https://fr.reddit.com/r/PHP/comments/2j ... lt_for_no/