I just got "system message: pirate version of app"

choddo
Joined: August 29th, 2010, 10:54 pm

May 1st, 2015, 7:05 pm

Like a full iOS pop up message.

Because of some XML error

Come on guys, that is ridiculous.

User avatar
mikeo
Joined: July 27th, 2013, 3:31 am

May 1st, 2015, 8:35 pm

choddo wrote: Like a full iOS pop up message.

Because of some XML error

Come on guys, that is ridiculous.
Please provide a screenshot for us to understand and investigate your issue?
AppStoreUpload - iOS Required Resource Files Prepared
No developer account required - Contact me for details!

choddo
Joined: August 29th, 2010, 10:54 pm

May 1st, 2015, 10:11 pm

Didn't get one sorry. Was so surprised. If it happens again will post.

choddo
Joined: August 29th, 2010, 10:54 pm

May 2nd, 2015, 12:50 pm

Here you go. I don't know what I tapped at the bottom to make this come up (I was trying to scroll at the time) - I don't have a tapatalk id.
ImageUploadedByTapatalk1430570922.550899.jpg
ImageUploadedByTapatalk1430570922.550899.jpg (72.72 KiB) Viewed 100 times

choddo
Joined: August 29th, 2010, 10:54 pm

May 5th, 2015, 2:35 pm

This is now happening all the time. It won't let me into a forum. Just pops up this dialog and wants me to enter my password again.

User avatar
caribe
6
Joined: May 5th, 2015, 8:44 pm

May 5th, 2015, 8:53 pm

Some problem here. I and my users get the same message "Pirate Version Of APP" on iOS and Android since a couple of days on my SMF forum. No problem on a second forum I have.

What are the possible reasons of such a message?

User avatar
mikeo
Joined: July 27th, 2013, 3:31 am

May 5th, 2015, 9:07 pm

Could you please confirm:
  • Your device type,
  • Installed version or build number of TT,
  • Installed version of iOS?
Thank you.
AppStoreUpload - iOS Required Resource Files Prepared
No developer account required - Contact me for details!

User avatar
caribe
6
Joined: May 5th, 2015, 8:44 pm

May 6th, 2015, 5:30 am

Installed version: 4.2.4 on SMF 2.0.10

On my iPad with iOS 8.3 I'm using TT 3.8
On Android 5.0.2 (smartphone) I'm using TT 4.13.3

As said before: I've an other forum (same SMF 2.0.10 with TT 4.2.4) and it works normally.

In addition in the forum owner control panel I got this message: "Your Tapatalk API installation (sm-2a) is expired. Update is required. (Latest version: sm-2a_4.2.4).". I first noticed this message when I was called to update to 4.2.3 and it's still there after I updated to 4.2.4.

After my support ticket finished unanswered I tried to uninstall the plugin a couple of times. I also tried to delete the two TT tables and settings before reinstalling it. I tried to set the SMF default theme. Nothing helped.

With some working on mobiquo/xmlrpcresp.php I'm able to let the message on the forum owner control panel to disappear, but it does not help to avoid the "Pirate Version Of APP" problem.

choddo
Joined: August 29th, 2010, 10:54 pm

May 6th, 2015, 6:03 am

iPhone 5S. Latest iOS. Latest TT. I also get the "you need to upgrade to 4.2.4" false warning after upgrading to that version.

That was already happening when the app was working though. I only started getting the error a few days ago and at first I could just cancel it. Now I get it always and it wants me to re-enter my forum password which it seems to have forgotten. About to try re-entering that.

choddo
Joined: August 29th, 2010, 10:54 pm

May 6th, 2015, 6:13 am

Didn't work. Same error.