[RVGL] [Release] 17.0115a

A well deserved dedicated forum for this project.

Moderators: Huki, jigebren

[RVGL] [Release] 17.0115a

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

15 Jan 2017, 14:42 #1

RVGL 17.0115a is released.
rvgl_17.0115a_win32.7z
rvgl_17.0115a_win64.7z
rvgl_17.0115a_linux.7z
rvgl_dc_pack.7z
changelog

P2P updates: P2P multiplayer is now the default mode. If you really want to host a client-server session, then set the "-nop2p" command line, otherwise no command line is needed.
Also, clients on the same LAN (like Passion and Pure) should now be able to see each other. Supporting this was tricky and required breaking compatibility once again, so everyone needs to download this new build.

New IP Server: I updated the Public IP provider to My External IP. I found it to be really responsive and reliable. It's maintained by someone who seems to be a nice guy. Anyway, if you do find it useful, send him a thank you note. :)

Camera Stuttering: I reverted the change in 1.2 related to stability at high fps, because it was found to cause some noticeable stuttering in the camera movement and other animations. Even without the change, I expect RVGL to be stable enough at high fps anyway. I think the main problem was the lights in Market1 flickering too fast, but that code was just buggy. I've now fixed that directly instead.

Note however that if you see some slight stuttering in moving objects, this is normal, because the Re-Volt physics engine is locked at 125 fps and will not function properly otherwise. There's currently no way to workaround this, although I posted a build with this limitation removed, just as an interesting test.


Huki
Reply
Like

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 19:07

15 Jan 2017, 19:57 #2

Audio is clipping in the 64 bit version.

A rocket that hit me seemed to have no effect at all.
Reply
Like

sebr
Methanolic
sebr
Methanolic
Joined: 29 Jul 2010, 17:26

15 Jan 2017, 21:20 #3

about audio it's the same with 32bit

at 47 fps = perfect sound but at 613 fps = bad "laggy" sound

probably because of that ?? =>

Code: Select all

Camera Stuttering: I reverted the change in 1.2 related to stability at high fps, because it was found to cause some noticeable stuttering in the camera movement and other animations. Even without the change, I expect RVGL to be stable enough at high fps anyway. I think the main problem was the lights in Market1 flickering too fast, but that code was just buggy. I've now fixed that directly instead.
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

16 Jan 2017, 04:35 #4

sebr @ 16 Jan 2017, 02:50 AM wrote: about audio it's the same with 32bit

at 47 fps = perfect sound but at 613 fps = bad "laggy" sound

probably because of that ?? =>

Code: Select all

Camera Stuttering: I reverted the change in 1.2 related to stability at high fps, because it was found to cause some noticeable stuttering in the camera movement and other animations. Even without the change, I expect RVGL to be stable enough at high fps anyway. I think the main problem was the lights in Market1 flickering too fast, but that code was just buggy. I've now fixed that directly instead.
Yes, there seems to be a problem with the doppler effects at high fps. The "laggy sfx" is noticeable when the car is moving fast. This doesn't happen with vsync on.

Can you check whether you (and Touriga) have the same problem in v1.2 15.0131?
Reply
Like

Kipy
Everclear-Addict
Kipy
Everclear-Addict
Joined: 25 May 2013, 12:17

16 Jan 2017, 06:41 #5

Huki @ 15 Jan 2017, 03:42 PM wrote: Also, clients on the same LAN (like Passion and Pure) should now be able to see each other. Supporting this was tricky and required breaking compatibility once again, so everyone needs to download this new build.
It worked already in earlier release (tested with my WiFi connection and could race 1v1 my PC and my laptop + late joiners could see us.
"Bisvil lircoch adam, ein corech leszfiach dam."
Reply
Like

Cosmo_Kramer
Alcoholic
Joined: 15 Feb 2011, 12:35

16 Jan 2017, 11:39 #6

yes the problem is the same at 0131
i was complaining about this issue a long time ago and noone could suggest anything,then suddenly,few realeses later,in one of your update,it just magikly was fixed..cant remmeber what realese it was but i think you wrote you were messing with sound a bit in that particular one
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

16 Jan 2017, 16:40 #7

I fixed the audio clipping issue. Just re-download the release.

Change log:
- fixed issue with doppler effect computation when fps is too high.
- removed '-p2p' command line and added '-nop2p'.

Kipy @ 16 Jan 2017, 12:11 PM wrote:
Huki @ 15 Jan 2017, 03:42 PM wrote: Also, clients on the same LAN (like Passion and Pure) should now be able to see each other. Supporting this was tricky and required breaking compatibility once again, so everyone needs to download this new build.
It worked already in earlier release (tested with my WiFi connection and could race 1v1 my PC and my laptop + late joiners could see us.
I'm guessing the host was also on the same LAN. The problem was when host is on a remote PC and 2 clients on LAN (your PC and your laptop) connect to that remote host. In that case it cannot work previously as we needed to do some special handling.
Reply
Like

SCracer
Sober
Joined: 14 Aug 2006, 16:21

27 Jan 2017, 06:51 #8

Huki,

With this version, 17.0115a, i get a low camera view at starts sometimes that doesn't revert back to the standard chase view (which is what i use, and i never change it) in some cases the view doesn't correct itself until i crash and repos. For this Months tracks, Miami Grand Prix produces this effect for me more than 50% of the time.

Also, I sometimes get a shifting of the camera position on many other tracks if i get close to walls or other objects, but not always. This causes the steering perspective to be off and i can't tell very well how much steering input to apply to correct my car's direction, since i'm viewing the car from the either side of it. It's almost like the camera itself is also avoiding hitting something, and rides along off center behind me for a short amount of time.

I have reloaded 16.1230a and these conditions never occur with that version.

Is there some setting i need to look at on my RVGL install?

Thanks!
Reply
Like

Killer Wheels
Alcoholic
Joined: 15 Jun 2005, 20:26

27 Jan 2017, 12:29 #9

Hey Huki !

I have a question you may be able to answer : is there a clue somewhere in the source code a visual polygon can be set to be unaffected by mirror planes ?

Thank you for you work ;)
Reply
Like

VaiDuX461
Methanolic
VaiDuX461
Methanolic
Joined: 02 Jul 2011, 16:02

27 Jan 2017, 12:42 #10

The low camera view getting stuck frequently happened to me as well. And its cause was, I'm quite sure, high fps. I always used Rear View key to properly revert the camera.
Since the last build was tweaked with framerate stuff again, it could be happening again.
I don't remember if those camera problems on high fps were solved in previous RVGL builds. Never paid attention tbh.

If it's a framerate problem, then solution is to turn v-sync on to limit fps, but this doesn't seem to work anymore on RVGL, so use LimitFPS = [number framespersecond] function in /profiles/rvgl.ini file to limit it instead.
aka VaidX47, Vaid
--------------------
>[MediaFire Stuff]< | >[Steam Profile]<
Reply
Like

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 19:07

28 Jan 2017, 01:47 #11

Hi All,

I've been using LimitFPS 240 for quite a while, don't know if this is still high fps for this camera issue but I also get it a lot more with 0115 opposed to 1230.

All the best,

Touriga
Reply
Like

Areno
Sober
Areno
Sober
Joined: 15 Aug 2015, 19:47

16 Feb 2017, 19:22 #12

I created a profile, but it's not showing in the profiles folder. Using the win32 version.

[Vaid]: Tried running the game as administrator?
Thanks. :thumbs-up:
Reply
Like

Yohanov
Sober
Joined: 19 Feb 2016, 19:59

16 Feb 2017, 22:21 #13

You are playing with 120hz/144hz monitor?
Reply
Like

Areno
Sober
Areno
Sober
Joined: 15 Aug 2015, 19:47

17 Feb 2017, 07:43 #14

Here's something odd. When I was running the game not as admin I was limited up to AA 8x, but running as admin it now supports up to AA 32x.
Reply
Like

MarvTheM
Alcoholic
MarvTheM
Alcoholic
Joined: 12 Jun 2010, 07:45

19 Feb 2017, 10:43 #15

I have some weird problems going on which actually sound like the sfx bug you seemed to have fixed, but it's still going on.

https://www.youtube.com/watch?v=59MCT-e5Ero

- the env is moving too fast
- the audio is glitching
- the arrows are acting weird

I'm on Linux (Arch) 64bit.
Limiting the fps to 60 seems to fix it.
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

20 Feb 2017, 19:07 #16

I'm releasing RVGL 17.0215a with a couple of bug fixes. Refer to the changelog for more details.
rvgl_17.0215a_win32.7z
rvgl_17.0215a_win64.7z
rvgl_17.0215a_linux.7z
rvgl_dc_pack.7z
changelog


The release should fix the low camera view with vsync off.
@Marv: Hopefully this release will fix your other issues too.
Reply
Like

MarvTheM
Alcoholic
MarvTheM
Alcoholic
Joined: 12 Jun 2010, 07:45

20 Feb 2017, 20:43 #17

That was quick! Thank you so very much!
Reply
Like

Kipy
Everclear-Addict
Kipy
Everclear-Addict
Joined: 25 May 2013, 12:17

27 Feb 2017, 08:31 #18

Still getting an 'error(?)', after 1-2 races or during the first race, host disappear, but others keep racing (and of course I can't, because I get the 'Multiplayer game terminated' message)
This happened only with several hosts, but I am sure it wasn't my internet connection, since it's speed is stable and didn't disconnected when this happened.
It started 2-3 versions earlier, but before this never happened.

What causing this?
"Bisvil lircoch adam, ein corech leszfiach dam."
Reply
Like

sebr
Methanolic
sebr
Methanolic
Joined: 29 Jul 2010, 17:26

09 Mar 2017, 21:43 #19

I found a straing bug



MMUD told me that :

Code: Select all

<mmudshark> you didn't see Absol
<mmudshark> using Alien Buster car
i saw this guy in race but can't remember if I read something from him on the game chat ...

re-volt.log

and can you give us back "-emulatefullscreen" without this the game is unplayable on windows 10 for me
Reply
Like

Black-Revolt001
Alcoholic
Joined: 19 Aug 2014, 18:31

13 Mar 2017, 14:30 #20

Problem with a printed screen / system that shows me this ...
https://image.noelshack.com/fichiers/20 ... image1.jpg

How to do a screenshot without this?
Reply
Like

MarvTheM
Alcoholic
MarvTheM
Alcoholic
Joined: 12 Jun 2010, 07:45

14 Mar 2017, 12:29 #21

You can press F8 to create a screenshot. All screenshots will then be in the profiles folder.
Reply
Like

Black-Revolt001
Alcoholic
Joined: 19 Aug 2014, 18:31

14 Mar 2017, 14:31 #22

MarvTheM @ 14 Mar 2017, 01:29 PM wrote: You can press F8 to create a screenshot. All screenshots will then be in the profiles folder.
Ha, thank you, but I found another solution ...

In the video option, there is an option generates mipmaps, just put no and it's good.
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

18 Mar 2017, 06:49 #23

sebr @ 10 Mar 2017, 03:13 AM wrote:I found a straing bug



MMUD told me that :

Code: Select all

<mmudshark> you didn't see Absol
<mmudshark> using Alien Buster car
i saw this guy in race but can't remember if I read something from him on the game chat ...

re-volt.log
The screenshot link is dead, can you reupload?
sebr wrote:and can you give us back "-emulatefullscreen" without this the game is unplayable on windows 10 for me
Are you talking about v1.2 or RVGL? RVGL runs fine on both my Win10 systems. Is there something wrong?
Reply
Like

sebr
Methanolic
sebr
Methanolic
Joined: 29 Jul 2010, 17:26

18 Mar 2017, 16:23 #24

My previous post is edited and all links are good now (Damn Dropbox !!!)

rv1.2(32 bit) works fine on my win 10 (64bit)
but
rvgl(32bit) can't go more than 45fps but works fine in window mode

[don't ask me to use 64bit soft :rolleyes: i got win 10 64bit because i didn't hade F****** choice !]
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

19 Mar 2017, 19:07 #25

sebr @ 18 Mar 2017, 09:53 PM wrote: rvgl(32bit) can't go more than 45fps but works fine in window mode

[don't ask me to use 64bit soft&nbsp; :rolleyes:&nbsp; i got win 10 64bit because i didn't hade F****** choice !]
Are you sure windowed mode works? I mean, if you maximize the window it gives full fps?

Can you post a re-volt.log from your Win10?

Did you try 64-bit RVGL? (don't understand what you mean by the last sentence :unsure: )
Reply
Like

sebr
Methanolic
sebr
Methanolic
Joined: 29 Jul 2010, 17:26

19 Mar 2017, 19:33 #26

Just tested and it's true if I maximize the window it NOT gives full fps :wacko:

w10 re-volt.log

I don't like 64bit OS because we can't use old dos like softs, and somtime we got strainge bug on 64bit soft that never hapens on 32bit ones ...


I'll try rvgl 64bit next week-end (this week will be busy)
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

19 Mar 2017, 19:50 #27

sebr @ 20 Mar 2017, 01:03 AM wrote:Just tested and it's true if I maximize the window it NOT gives full fps  :wacko:

w10 re-volt.log
Very strange because opengl support on Nvidia / AMD on Win10 is usually quite good. You can try downloading the latest Win10 64-bit drivers from the nvidia website and do a clean reinstall (i.e., uninstall old driver completely and install new one).

sebr wrote:I don't like 64bit OS because we can't use old dos like softs, and somtime we got strainge bug on 64bit soft that never hapens on 32bit ones ...

I'll try rvgl 64bit next week-end (this week will be busy)
Ok, I thought you said you didn't want to try 64-bit rvgl. ;) I suggest you to try 64-bit rvgl first when you get free time, then if the issue persists, update drivers as above.
Edit: The latest Nvidia driver for your card is 378.78 (here).
Reply
Like

Black-Revolt001
Alcoholic
Joined: 19 Aug 2014, 18:31

23 Mar 2017, 12:45 #28

Hello everyone

I just installed RVGL, but I have a concern for its ...
I do not hear the engine of my vehicle, nor skid and some are power-ups

Where does the problem comes from ?
Reply
Like

sebr
Methanolic
sebr
Methanolic
Joined: 29 Jul 2010, 17:26

25 Mar 2017, 14:27 #29

Huki @ 19 Mar 2017, 08:50 PM wrote: Edit: The latest Nvidia driver for your card is 378.78 (here).
Just need a driver update (378.92)

(now i can check the last update)
Reply
Like