[RVGL] Multiplayer thread

A well deserved dedicated forum for this project.

Moderators: Huki, jigebren

[RVGL] Multiplayer thread

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

14 Sep 2016, 08:37 PM #1

I'm opening this thread to discuss all things related to RVGL's multiplayer support, to gain feedback about areas that need improvement, and to post test builds for interested testers to try out. If any of you are recording online sessions, you can post those here too (but mention the version / build shown in the video).

First, I'll be leaving some info on current limitations of RVGL's network model, and generally some tips to improve your experience online.
1) The network model I chose for RVGL is client-server. This means, each player is connected only to the host, and it is only the host that updates all the players with the happenings of the game. This has both pros and cons, the pros being: cleaner code and no need for clients to open ports, and the cons: heavier load for the host to handle, and increased delay for one player's action to pass through the host and reach the other player.
2) The client-server model has certain implications for online sessions with players from countries across the world. In these cases, a good host is someone who has both a high bandwidth and a low ping with other players. The bandwidth question is clear, but the ping depends on the geographical distance between players. To make things simple, the host should be someone who lives close to the majority of players in the session.
Eg., If there are 5 players living in the US and 2 in Spain, the host should be one of the US players.

My future work in this area will be (as time permits...):
1) Improve the client-server model by focusing on more accurate gameplay predictions and interactions between players.
2) Provide optional support for P2P (peer-to-peer) multiplayer (will require each player to open one UDP port).

I'll be posting here as and when there are test builds available - these builds will likely not be compatible with mainstream RVGL builds. If you're following this thread and wish to help improve the online support, feel free to get together and host a few sessions with the test builds, feedback and videos welcome. :)

Huki
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

17 Sep 2016, 08:30 PM #2

Suggestion: what about enabling debugging replays? in that manner it could be explored closely.
and debugging ui plus logs for additional information, maybe unnecessary but it's actual evidence to not rely on players observation, they could be wrong (no offense)
could the replay system extended/improved perhaps?
last time i tried with a friend rvgl was pretty stable, besides having a good upload speed and ping the host should have a stable internet as in dropping doesn't leave a ghosted connection

im up for testing by the way
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Cosmo_Kramer
Alcoholic
Joined: 15 Feb 2011, 12:35 PM

23 Sep 2016, 08:34 PM #3

We have done a round of races with last update.
I can say i noticed that sometimes,a car kind of when its hit by a weapon,takes some weird position for a second or so, and continues to drive in that position for a very short time,which is very weird!
That's all i can say from writing part .I think someone was recording also,so hoping for a video to found out more
Quote
Like
Share


VaiDuX461
Methanolic
VaiDuX461
Methanolic
Joined: 2 Jul 2011, 04:02 PM

25 Sep 2016, 06:41 PM #5

Just posting this to confirm whatever Cosmo has reported.

The main problem with the latest multiplayer changes is car rotation. Looks like it doesn't get updated as often (or as quickly) as it used to be. Car position, however, seems to be updated more frequently than rotation, causing this weird flying/sliding look (also power sliding) at random moments.

Take a look here: https://youtu.be/4ux2UxtKC9w?t=3m53s URV's car rotation is handled quite slowly.
Another example: https://youtu.be/9vETb7wg1TQ?t=2m37s (power slide example)
https://youtu.be/yDjoaEbRuSk?t=59s (Ciccio's car)

From my personal experience, I've seen some cars driving upside down for 1 second, until rotation slowly caught up.
aka VaidX47, Vaid
--------------------
>[MediaFire Stuff]< | >[Steam Profile]<
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

25 Sep 2016, 08:00 PM #6

Thanks for the videos, yes the rotation appears to be too slow in a lot of places. On the bright side, the weapon response seems better, the perceived car positions are more accurate (i.e., they are no longer "fake"). But the slower rotations can lead to a lot of weirdness. Tomorrow we'll see with an updated test build.
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

26 Sep 2016, 01:40 AM #7

For me it seems it worsen:
there were more collision glitches like cars hugging walls, and cars were advancing in a impossible angle.
weapon responsiveness didn't improve much.
i would prefer to have teleporting and delay than smoothness. the actualy position seems to be farther from me.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

27 Sep 2016, 10:37 AM #8

Getting back to this, there are 2 different issues seen in the videos, even though it looks like the same issue:
- One is that the cars stay at an odd angle (or even upside down) for some time and slowly return to the correct orientation.
- The other is that the cars take a wider trajectory than normal and crashes into walls / drives out of the edge, as seen in the URV example in Jailhouse.

In fact, only the first issue is the result of slower car rotation. The second issue - power sliding, wall hugging, and cars seeming to drive outside the correct path; these are rather caused by lag. It's noticeable in this release because I disabled the remote delay. At very high client-to-client pings, the car position can no longer be accurately predicted, so it seems we do need to add some delay to the animation.

The previous rvgl versions (and v1.2) add a lot of delay so that the car animations are perfect. But this also makes weapons practically useless at high pings (eg, car still appears behind you when it's really ahead of you). The latest rvgl has no added delay, but the predicted trajectory can become weird. It's still better because of the new animation model, but it's not good enough.

I've now tried to bring a balance between using the delay of previous versions and the new animation of the latest version. Hopefully it should be good. The nice part is that, if it's even nearly as good as v1.2, this means it will be much better once P2P is supported. :D

Soon I'll update this post with a new test build.

EDIT:
Here's the test build, just extract it over the latest release.
rvgl_16.0927a_test_win32.7z
rvgl_16.0927a_test_win64.7z
rvgl_16.0927a_test_linux.7z

Changelog:
- Restored the remote delay (to a lesser extent than before).
- Make sure remote car orientation doesn't deviate too much from correct angle.
- Weapon transfer now uses guaranteed messaging.
- Show CHT online if a player is using dev mode.

Note that the build is not backward compatible, so all players in the session should use this build.
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

28 Sep 2016, 07:03 AM #9

Was very fun to race this test version yesterday.

Saw once DrPepper sliding.

I could only see pings randomly and Pepper was showing 300ms sometimes which is very high.

THANKS!
Quote
Like
Share

Cosmo_Kramer
Alcoholic
Joined: 15 Feb 2011, 12:35 PM

28 Sep 2016, 12:16 PM #10

Interesting,i also saw only pepy sliding,and in one situation,was not able to zapp
one player in front of me that showed i think -2m to me.Other weapons seem to work great and i think we have a slight improvement comparing to previous rvgl realeses :thumbs-up:

but lets not rush with conclusions :D
Quote
Like
Share

VaiDuX461
Methanolic
VaiDuX461
Methanolic
Joined: 2 Jul 2011, 04:02 PM

28 Sep 2016, 04:16 PM #11

Only few players were still sliding, but it's definitely an improvement over the last version. Probably even better than previous RVGL builds.
aka VaidX47, Vaid
--------------------
>[MediaFire Stuff]< | >[Steam Profile]<
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

29 Sep 2016, 07:42 AM #12

VaiDuX461 @ 28 Sep 2016, 05:16 PM wrote: ...Probably even better than previous RVGL builds. ...
Agreed :-)
Quote
Like
Share

RichyDude
Sober
Joined: 25 Jun 2015, 05:24 PM

29 Sep 2016, 04:46 PM #13

Anyone doing any online multiplayer racing during lunchtime (GMT)? There's 5 of us that wouldn't mind going up against different people for a change :)

I've downloaded and ran that update by the way, no bugs to report.
Quote
Like
Share

Phantom
100% Proofer
Phantom
100% Proofer
Joined: 21 Mar 2011, 04:01 PM

30 Sep 2016, 01:15 AM #14

Just out of curiosity, for those of us that do not use RVGL, would it be possible to see that new lag management approach introduced in Re-Volt v1.2? I'm curious to see if it's really that good.
We don't stop playing because we get older, we get older because we stop playing.
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

30 Sep 2016, 08:27 AM #15

Phantom @ 30 Sep 2016, 02:15 AM wrote: Just out of curiosity, for those of us that do not use RVGL, would it be possible to see that new lag management approach introduced in Re-Volt v1.2? I'm curious to see if it's really that good.
Will be difficult to beat 1.2 p2p approach.
Quote
Like
Share

nero
100% Proofer
nero
100% Proofer
Joined: 27 Jun 2008, 02:28 PM

30 Sep 2016, 05:38 PM #16

Phantom @ 30 Sep 2016, 01:15 AM wrote: would it be possible to see that new lag management approach introduced in Re-Volt v1.2?
Less time spent on 1.2 is more time spent on RVGL.
Saffron.
Quote
Like
Share

Dolo
Alcoholic
Dolo
Alcoholic
Joined: 26 Feb 2012, 04:58 PM

30 Sep 2016, 08:09 PM #17

Phantom @ 30 Sep 2016, 02:15 AM wrote: I'm curious to see if it's really that good.
Given the great bunch of noobs present in this topic, it would be very surprising that this is the case...
Quote
Like
Share

Phantom
100% Proofer
Phantom
100% Proofer
Joined: 21 Mar 2011, 04:01 PM

30 Sep 2016, 11:18 PM #18

Again, I repeat that my question is for those of us that do not use RVGL. I'm not interested in RVGL's development the same way that you may not be interested in v1.2 anymore. I don't expect you to understand and knowing the current unfortunate state of this community, I don't expect you have a little respect on that either. But I'm curious if this has any chance to benefit the only thing that keeps me and my friends tied to this game, Re-Volt v1.2. In case it doesn't, I'm fine with the current state of v1.2 as it is but I still hope for some changes and small fixes to be made in some moment.
We don't stop playing because we get older, we get older because we stop playing.
Quote
Like
Share

nero
100% Proofer
nero
100% Proofer
Joined: 27 Jun 2008, 02:28 PM

2 Oct 2016, 12:11 PM #19

Again, I repeat that my question is for those of us that do not use RVGL.
The needs of the many outweigh the needs of the few. Also, keep in mind you've posted a 1.2-related question in an RVGL thread.
I'm not interested in RVGL's development the same way that you may not be interested in v1.2 anymore.
When did I ever say I'm not interested in 1.2 anymore? I simply hinted at the fact that it is obsolete.
I don't expect you to understand
Given the great bunch of noobs present in this topic, it would be very surprising that this is the case...
Aside from my musical taste, I can't really relate to people stuck in the past.
I don't expect you have a little respect on that either.
Somebody's a bit insecure.
Saffron.
Quote
Like
Share

Phantom
100% Proofer
Phantom
100% Proofer
Joined: 21 Mar 2011, 04:01 PM

2 Oct 2016, 06:57 PM #20

And somebody's being a little harsh when there's really not need to.

[HIDE=Offtopic]Nothing I wrote until now was meant for you personally nero so I hope you don't take anything personal and stop replying as if wasting time on RV1.2 would affect your life in any way. If you're trying to look for a quarrel, I'm not interested.

I'm sick of the amount of aggression between players and irrational disrespect that has been the top trend in the last couple of years.[/HIDE]
Spending time on something 'obsolete' is only up to Huki to decide. And judging by the fact that he has spent years and years of his time on a game considered by the rest of the world as obsolete with such a low number of players already, I wouldn't be surprised to expect one or two bug-fixes for v1.2, as he has already announced before when he said that he will keep it updated from time to time.

Feel free to split up the topic from my question on Sep 29th if you think it is that important. Now, gentlemen, please go back to your RVGL discussions and please ignore my little question to Huki.
We don't stop playing because we get older, we get older because we stop playing.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

3 Oct 2016, 05:19 PM #21

Phantom @ 30 Sep 2016, 06:45 AM wrote: Just out of curiosity, for those of us that do not use RVGL, would it be possible to see that new lag management approach introduced in Re-Volt v1.2? I'm curious to see if it's really that good.
Yes and no. Some of these changes take advantage of RVGL's new network code based on ENet. They won't work on v1.2's DirectPlay. For example, ENet's dynamic throttling capabilities lets us push more packets per second, resulting in far better utilization of bandwidth. This in turn decreases the effective ping.

The v1.2 network code is probably as good as it gets. Chances of further improvement are slim. Also keep in mind that the new changes are still experimental and RVGL's network code as a whole is still evolving. It doesn't make sense at this point to think about getting those changes into v1.2.

With that said, a v1.2 maintenance release with bugfixes from RVGL is not ruled out. I think I mentioned it before. I might take another look at v1.2's network approach at that time.
Quote
Like
Share

Dolo
Alcoholic
Dolo
Alcoholic
Joined: 26 Feb 2012, 04:58 PM

17 Dec 2016, 08:47 AM #22

On the Current RVGL, collisions are far too strong in general, which is a real disadvantage when traffic is high. Even the sound that translates these impacts into the game ends up tapping the nervous system ...
And this is not a physical problem, just a consequence of lag management.
The opposing cars should have less impact on the local player, and allow better playability especially when traffic is high, as may be the case with older versions such as 1.1 or beta, which makes the Gameplay much more enjoyable ...
I think there is still room for improvement at this level.
Quote
Like
Share

Joined: 24 Sep 2014, 05:08 PM

21 Dec 2016, 07:42 PM #23

Huki I just want to say that in the current version of RVGL [16.1210a], but also in the previous ones (at least in one version back, I can't say exactly since when it started happening as I was less active at that time). I get no countdown bug when starting a race in multiplayer (as a player who is joined, not as a hoster). It doesn't have to be a restarted track, simply host starts a race/ new track => I get a bug. It's not only me, but also at least Valepescarese has this bug. This bug causes:

- no countdown, instant start
- massive lag (phone at the left + other cars flash and lag)

It's been before, but only in 1.2 (when 1.2 and after RVGL was installed - but bugs are expected in 1.2, as RVGL changes files so 1.2 bugs). Now it's in a clear, new install of Revolt and RVGL (no 1.2)...
Quote
Like
Share

Kipy
Everclear-Addict
Kipy
Everclear-Addict
Joined: 25 May 2013, 12:17 PM

22 Dec 2016, 06:48 PM #24

RVGL has a weird lag, it's sure, and experienced lack of countdown sometimes as ZipperZ mentioned.
Most disturbing is the strange lag (cars driving on 2 wheels backward or upside down)
This wasn't like this in earlier versions (I mean 1.2, specially beta)
"Bisvil lircoch adam, ein corech leszfiach dam."
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

23 Dec 2016, 04:29 AM #25

Note: I moved both your posts to the dedicated multiplayer thread. Be sure to discuss RVGL multiplayer issues here so I can review them in one place.
___

@zipperz and @Kipy: This can only happen if your connection with the host was really bad. Who was the host during that time, and how many other players were present? Did any of the other players complain of lag too?

I also need to see your re-volt.log generated after the buggy session as it logs your ping with the host. The next time you experience lag or countdown issues, post the generated log.


Btw, I have some news: I've now added P2P support to RVGL. The only tricky part is to handle the port forwarding situation for each client. I need help to test how this is working (need at least 3-4 players). I'll drop by RVHouse and Discord. If anyone is interested in testing, let me know and I'll get a test build ready.
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

23 Dec 2016, 11:24 AM #26

Hi Huki,

I'm definitely interested in testing p2p and I'll be able to find 3 or 4 players to do so.

I'm currently running 64bits rvgl.

Million thanks for all your efforts in 2016 and wishes of a Merry Christmas, may 2017 be full of Health, Peace, Love, Luck, Sex and some money for the expenses to you and all your Family.

Touriga
Quote
Like
Share

Kipy
Everclear-Addict
Kipy
Everclear-Addict
Joined: 25 May 2013, 12:17 PM

23 Dec 2016, 11:45 AM #27

If there are full room like the last sessions had, there is always lag whatever who host, and the lag as weird as I wrote earlier.
It's the same when I host or when someone else host. When I host, players hardly complaining about the lag, when someone else host I don't complain, because lag is minimal or I can still play with this lag, I don't like to whining, I want to race only.
But this is very disturbing already. No idea where I can find log file, but if I'll have time and won't forget about it, I'll send you here.

Oh, and I am interested in tests as well, PM me in Discord, and will reply.
"Bisvil lircoch adam, ein corech leszfiach dam."
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

24 Dec 2016, 05:30 PM #28

I've finally fixed the "no countdown" bug. Everyone in the session should download and use this test build.

rvgl_16.1220a_win32_test.7z
rvgl_16.1220a_win64_test.7z
rvgl_16.1220a_linux_test.7z

The problem was not related to 64-bit or late joining like we thought yesterday. It was caused by a lack of synchronization when the clients finished loading even before the host starts loading (i.e., when the host is still on the sync screen). In fact, it's an old bug that also exists in 1.2, but maybe clients didn't have superfast computers then... or rvgl loads quicker. ;) The test build should definitely fix it, so let me know how it works.
Quote
Like
Share

benvoliosaythat
Regular
Joined: 19 Aug 2006, 12:23 PM

27 Dec 2016, 12:38 AM #29

Dont work for me :

- the 64 bits make an error about language
- the 32 bits dont launch nothing

Thx for your work Huki (in general) but there is a trouble, we need a stable version of game.
Personnaly i dont need to loose all my time to change version every time you find a little bug .. its maybe a job you like but we depend of you .. and tonight i lost 30 min and the game dont work.

I am developper also and when i find a small bug i dont force 100 players to change of version .. i wait for a big release.

Ben
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

27 Dec 2016, 10:36 AM #30

Sorry Ben but I think your problem has just to do with the user and poor installation.

Nobody else reported anything similar.

That's a test version for a bug experienced recently and that we are all testing at the moment.

For the vast majority it was just a simple extract to the correct folder for it to work.

Don't take what you go through as granted for others, its unfair.
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

28 Dec 2016, 11:15 PM #31

Problems with running the game are most of the time human errors.

Perhaps a better update delivery system can be used.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

29 Dec 2016, 03:06 AM #32

Ben has already solved his issue, but in case anyone else suffers from it: it's most likely corrupt data files or a 32-bit/64-bit mismatch. Make sure you install the latest release build first (as of now 16.1210a) before trying any test build, and always choose the same variant (either 32-bit or 64-bit) in both cases.

@ben: Network version is incremented only when there has been a protocol-breaking change and the new build can no longer communicate with older builds. When this is done, it's clearly mentioned in the RVGL changelog (look for the note that says "Pumped network version"). You can see that the last time it happened was in September, meaning all builds since 16.0927a have remained compatible with each other until the last test build. The 16.1220a has undergone various internal changes (to support P2P), so it's unfortunately no longer compatible with previous builds.


P2P Test: For the curious and brave, I have new P2P test builds - don't replace your current rvgl binary with this one, just keep it separate and host/join through in-game, using the host's IP. As with the previous P2P builds we tested in RVHouse, the idea is to see if clients can communicate with each other without port forwarding. The build will select a random port for each client, so don't be surprised if it doesn't work (but I hope it does). Check if clients can see each other's chat messages, and post a log after your game.
rvgl_p2p_test4.7z [win32, win64 and linux binaries included]
Quote
Like
Share

mmudshark
Regular
Joined: 4 Apr 2011, 03:04 AM

30 Dec 2016, 12:22 AM #33

Dolo, DJ, Raf, Cosmo, and I used test4 by ip today. Everyone could see each others chat and the only issue was 'no countdown' for DJ a couple of times and Raf once I think. There was nothing in my revolt.log so hopefully they will have theirs to post. The game play and collisions were both good.
Quote
Like
Share

Dolo
Alcoholic
Dolo
Alcoholic
Joined: 26 Feb 2012, 04:58 PM

30 Dec 2016, 09:34 AM #34

The countdown bug is happened only when i hosted, like the other day after restarting track.
With Mmud it was OK.
No Log during the first test because it was erased by the second test.
The close fight between cars was much more interesting because the contacts seemed normal, which avoids crashing all the time ...
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

30 Dec 2016, 11:55 AM #35

I WILL SEE A PIG FLY!!!

Dolo is positive about something :-)

I must try this urgently but yesterday was a messy day.
Quote
Like
Share

Touriga
Regular
Touriga
Regular
Joined: 23 Aug 2012, 07:07 PM

30 Dec 2016, 07:35 PM #36

Hi Huki,

Hosted a session today with p2p ver.

Lukadeon couldn't see me.

Cosmo couldn't see other player but rejoined and issue disappeared.

LOG

I could see Boban (laggy player) teleporting a lot, same with other players.

Thank you and Happy New Year.

All the best,

Touriga
Quote
Like
Share

Cosmo_Kramer
Alcoholic
Joined: 15 Feb 2011, 12:35 PM

30 Dec 2016, 08:19 PM #37

As tour said,i couldnt see Lukadeon and passion for some reason.After quickly rejoining,all players were visible and racing.And only boban was teleporting during races,others were not,at least to me.
http://www.pastebin.ca/3750783
Quote
Like
Share

Dolo
Alcoholic
Dolo
Alcoholic
Joined: 26 Feb 2012, 04:58 PM

30 Dec 2016, 08:53 PM #38

Please do not need to report teleporting as an abnormality that you must absolutely eradicate,
a laggger must lag and must have an unstable position on the road, it's only logical...
Quote
Like
Share

Dolo
Alcoholic
Dolo
Alcoholic
Joined: 26 Feb 2012, 04:58 PM

30 Dec 2016, 11:45 PM #39

It's clearly the best feeling that i got on a build since long time in multiplayer race.
I can't explain why all is different, but it is... weapons, crashings, collisions with cars and walls, response of the car...
I always said that the all gameplay could change depends of the code or the way how lag was managed...
And this proves one more time that my memories of the 1.1 was not a mirage...
Quote
Like
Share

mmudshark
Regular
Joined: 4 Apr 2011, 03:04 AM

31 Dec 2016, 01:06 AM #40

We did another p2p_test4 with Dolo hosting after Tour hosted earlier and it was excellent.
8 players (in a few of the races) on custom tracks with no pickups and the game play was the best I've seen in a long long time. Close racing with no extreme crashes but the normal minor crash when someone bumped you.
My game still doesn't generate a revolt.log so one of the other guys can post theirs if necessary.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

31 Dec 2016, 11:09 AM #41

So it actually works? :o That's really good news, although some players were occasionally not able to see each other without re-joining and I wonder why.

The bad news is the 'no countdown' bug:
mmudshark wrote:Dolo, DJ, Raf, Cosmo, and I used test4 by ip today. Everyone could see each others chat and the only issue was 'no countdown' for DJ a couple of times and Raf once I think.
Dolo wrote:The countdown bug is happened only when i hosted, like the other day after restarting track.
With Mmud it was OK.
I need a log from the player who experienced the bad countdown to be able to figure out what happened. It's probably erased by now, but just remember the next time any player gets a bad countdown, that player should get the log after the session is over.
mmudshark wrote:My game still doesn't generate a revolt.log so one of the other guys can post theirs if necessary.
The file is saved in the profiles folder: <re-volt folder>&#092;profiles&#092;re-volt.log. Are you sure you're looking in the right place? Don't look in C:&#092;temp, etc., those were used only by v1.2 and older.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

31 Dec 2016, 07:29 PM #42

Huki @ 31 Dec 2016, 04:39 PM wrote: The bad news is the 'no countdown' bug:
mmudshark wrote:Dolo, DJ, Raf, Cosmo, and I used test4 by ip today. Everyone could see each others chat and the only issue was 'no countdown' for DJ a couple of times and Raf once I think.
Dolo wrote:The countdown bug is happened only when i hosted, like the other day after restarting track.
With Mmud it was OK.
I need a log from the player who experienced the bad countdown to be able to figure out what happened. It's probably erased by now, but just remember the next time any player gets a bad countdown, that player should get the log after the session is over.
Ok, I tested today with Dolo and sebr and we tracked down the bug. The bug still occurred when the same track is restarted again. This time it's fixed for good (wait for a release announcement which should be quite soon).
Quote
Like
Share

URV
Regular
URV
Regular
Joined: 14 Dec 2010, 10:13 AM

14 Mar 2017, 08:35 PM #43

We just found a major issue during the races today: If there are more than 16 players joining the session, the game will crash. I've had that happen thrice today, and we confirmed it afterwards by having someone join multiple times until we reached 17 players.
Quote
Like
Share

Black-Revolt001
Alcoholic
Joined: 19 Aug 2014, 06:31 PM

16 Mar 2017, 02:44 PM #44

How do you play online with RVGL, because I would like to test.
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

16 Mar 2017, 04:31 PM #45

install rvgl and put the path in rvhouse settings
you wouldn't be asking this if you had some logic or common sense.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Black-Revolt001
Alcoholic
Joined: 19 Aug 2014, 06:31 PM

17 Mar 2017, 02:22 PM #46

RV House not detected rvgl in folder...
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

17 Mar 2017, 03:53 PM #47

[HIDE]Ensure it's actually your rvgl folder with rvgl.exe


Put that path in RVHouse settings and restart
[/HIDE]
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

18 Mar 2017, 06:51 AM #48

URV @ 15 Mar 2017, 02:05 AM wrote: We just found a major issue during the races today: If there are more than 16 players joining the session, the game will crash. I've had that happen thrice today, and we confirmed it afterwards by having someone join multiple times until we reached 17 players.
Good find, I'll check that.
Quote
Like
Share

Santiii727
Regular
Joined: 6 Dec 2014, 12:15 AM

25 Mar 2017, 10:31 PM #49

I found this, i entered late join and only see the host playing, but the others no. Some people also has timed out today or Multiplayer Game Terminated. I do not know what problem is -_-


[youtube][/youtube]
Quote
Like
Share