Moderators: Huki, jigebren

ThugsRook
Alcoholic
ThugsRook
Alcoholic
Joined: 28 Sep 2014, 05:50 PM

20 Nov 2014, 10:26 PM #1951

just to state the completely obvious...

you should be using vsync in all games.
no game was ever made with unlimited fps in mind, ever.
Quote
Like
Share

Alphacraft
Regular
Joined: 18 May 2011, 01:39 AM

21 Nov 2014, 05:04 AM #1952

I wouldn't say all games, if you have an entry-level graphics card and you're trying to max out just-released-uber-grafix-AAA-game, then V-sync is bad.

Yes, I'm splitting hairs :P
The Obsoletist, a YouTube channel about making the most of old technology.

Formerly known as pawer126
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

21 Nov 2014, 01:19 PM #1953

lol you two

----------------

about the btag timer bug i tested, timer goes slow and fast randomly on ~800fps vs ~160fps tag.
Hmm, maybe it has to do with actual ping.

can anyone try in LAN? (FPS must be beyond 100 on each test machines, 0ms network may help, try with gigabit lan if possible. also if you can, use a lag simulator after the initial 0 ms test and tell us how it behaves in 100, 200, 250 and 300ms :)
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

}!{enR
Regular
}!{enR
Regular
Joined: 17 Nov 2012, 05:07 PM

22 Nov 2014, 06:25 PM #1954

pawer126 @ Nov 21 2014, 11:04 AM wrote:if you have an entry-level graphics card and you're trying to max out just-released-uber-grafix-AAA-game, then V-sync is bad.
Hmm... Actually, if you are trying to play some modern game with high settings on an entry-level graphics card, then you'd better enable the VSync, because it makes the game with low fps rate run more smoothly...
_____________________
Abc @ Nov 21 2014, 07:19 PM wrote:about the btag timer bug i tested, timer goes slow and fast randomly on ~800fps vs ~160fps tag.
Hmm, maybe it has to do with actual ping.
It may have something to do with a packets loss.
IIRC, some similar timer bug has been discovered some time ago, and has been fixed.
a.k.a. EvgenKo423
Quote
Like
Share

Alphacraft
Regular
Joined: 18 May 2011, 01:39 AM

23 Nov 2014, 03:45 AM #1955

}!{enR @ Nov 22 2014, 12:25 PM wrote: Hmm... Actually, if you are trying to play some modern game with high settings on an entry-level graphics card, then you'd better enable the VSync, because it makes the game with low fps rate run more smoothly...
If only that were the case; it actually limits the framerate to some fraction of the display refresh rate. If you're getting 28 fps in a game without V-sync on a 60 Hz monitor, V-sync will drop it to 20 fps. 54 -> 30 fps, 18 -> 15, etc. It's better IMO to just let the graphics card do what it can and deal with fluctuating framerates rather than have sharp spikes from one fraction of the refresh rate to another.
The Obsoletist, a YouTube channel about making the most of old technology.

Formerly known as pawer126
Quote
Like
Share

ThugsRook
Alcoholic
ThugsRook
Alcoholic
Joined: 28 Sep 2014, 05:50 PM

23 Nov 2014, 04:06 AM #1956

hey, if youre playing a game with a fps below vsync thats your problem :P ;)

modern drivers typically will drop the fps in half to 30 when below 60fps, not good.
Quote
Like
Share

Alphacraft
Regular
Joined: 18 May 2011, 01:39 AM

23 Nov 2014, 05:01 AM #1957

What can I say? I don't like spending money for good hardware when mediocre hardware will do :lol:
The Obsoletist, a YouTube channel about making the most of old technology.

Formerly known as pawer126
Quote
Like
Share

jhs
Sober
jhs
Sober
Joined: 17 Nov 2014, 08:34 PM

24 Nov 2014, 08:13 PM #1958

Phantom @ Nov 18 2014, 02:51 AM wrote: It simply shouldn't happen. The newest alpha 0820 and newer sub-versions are super stable and don't crash unless you have a custom car or track causing a problem. Maybe some of the add-ons you have installed is causing a problem with Platinum Cup.

Try this portable version of the game that doesn't include add-ons and compare if it crashes here: http://dl.dropboxusercontent.com/u/1040 ... rtable.rar

If this revolt that I am giving you crashes too, the cause of the blackscreen probably comes from your computer. Fragmented disk for example or incompatible graphic card, outdated drivers, etc.
I uninstall all version of Re-volt that i had on my computer.

I installed portable version. And 14.0208 from http://revoltfrontend.wordpress.com/. I added Milkfix update, OGG music, shark car shadows, music patch, amw and cougar patch, 32-bit update and some stuff(Rooftops map). I drove all Re-Volt without problem. All cups, maps, mods, internet, settings, cars works properly. SUPER !! Great works :) who did this updates

You talking about 14.0820 ... i have the newest 14.0208, i found this http://revoltfrontend.wordpress.com/ .

Somewhere I heard talk about the version 14.0831 .. how version is the newest and where can i donwload it ? And some changelog will be good :) i find only this http://rv12.revoltzone.net/downloads/rv ... ngelog.txt

THX for answers.
Quote
Like
Share

Phantom
100% Proofer
Phantom
100% Proofer
Joined: 21 Mar 2011, 04:01 PM

25 Nov 2014, 12:50 AM #1959

Good news that you've fixed your problem.

We don't know if this project is dead or not and we haven't heard any news about a new project in long long time so I cannot answer your question. It looks like it's more than dead and this site looks abandoned, but who knows in the far far future.

The theoretical last version is the 14.0208 but nobody uses it. We all hope that it doesn't remain the last. For the moment we use the 13.0820 which can be downloaded from the official site here or the 14.0306 which is a mini-update to test experimental things and can be downloaded here. The 14.0306 has a better track selector and a better lag management for multi-player, nothing else.
We don't stop playing because we get older, we get older because we stop playing.
Quote
Like
Share

jhs
Sober
jhs
Sober
Joined: 17 Nov 2014, 08:34 PM

28 Nov 2014, 08:09 PM #1960

B) So OK.

I donwloaded 14.0306 ... thx for answers ... its awesome to see how some people improved the game !!

THX for good job ! ;)

'm excited for possible updates.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

26 Jan 2015, 07:03 PM #1961

Re-Volt v1.2 has been updated.
This is a maintenance update that brings a few fixes and reverts. Check the readme for the complete change log.

Download the new Alpha release 15.0125 here (readme).

The website is also updated. We've added an announcement at the top of the page to inform people about the upcoming project. It's now easier to find and download the latest alpha, and the FAQ has been revised. Do note that some pages may still be incomplete / missing.

If the website doesn't display correctly, you might have to clear the cache and / or refresh the page (F5).


~ Huki & jigebren
Quote
Like
Share

Alphacraft
Regular
Joined: 18 May 2011, 01:39 AM

26 Jan 2015, 08:21 PM #1962

Great job, both of you! It's not running on OpenGL but we'll take it :)

On another note, would it be reasonable to expect this new release to eclipse 13.0820 for multiplayer? I love 14.0208 for single player because of the Vorbis support, but there're apparently zero other people who want to use it. Here's hoping this new version will gain steam in that regard.

I'm all about progress, so it's encouraging to see a renewed effort toward active development. Keep up the great work!
The Obsoletist, a YouTube channel about making the most of old technology.

Formerly known as pawer126
Quote
Like
Share

RV_Passion
Regular
Joined: 30 Dec 2011, 07:46 PM

26 Jan 2015, 09:29 PM #1963

It's so wonderful to see that the 1.2 stuff and the willingness still goes on. :)

Btw, I want to make a logo for your "Re-volt - OpenGL" project for your 1.2 website.
DOH never stop!
Quote
Like
Share

}!{enR
Regular
}!{enR
Regular
Joined: 17 Nov 2012, 05:07 PM

27 Jan 2015, 09:06 AM #1964

- The keys in the numeric keypad are now re-enabled for Player 1.
It's great, thanx!
RV_Passion @ Jan 27 2015, 03:29 AM wrote:It's so wonderful to see that the 1.2 stuff and the willingness still goes on.  :)
Yeah, nice to see you here again, Huki!
a.k.a. EvgenKo423
Quote
Like
Share

jigebren
... as a Newt
jigebren
... as a Newt
Joined: 5 Dec 2009, 11:38 PM

27 Jan 2015, 08:29 PM #1965

pawer126 @ Jan 26 2015, 09:21 PM wrote:On another note, would it be reasonable to expect this new release to eclipse 13.0820 for multiplayer?
I don't really think so, at least not yet. We're precisely looking whether there's still any chance to make this code more stable for multiplayers, and if we can't get some results there'll be another release.
RV_Passion wrote:Btw, I want to make a logo for your "Re-volt - OpenGL" project for your 1.2 website
This is both very nice and... embarrassing. ;) I mean, this is something we could do eventually (we already have something almost ready in fact), but this sure wasn't our top priority. Now imagine we don't like it, it'll be hard to say no then if we have told you: "yes, go on" before. Anyway, any proposition like this is welcome as it sounds supportive and motivating for us, and I imagine it does for you as well. So if you have any idea feel free to to strike while the iron is hot and let us know what you came up with (in public or in private), even though this is not an official request. :P
Quote
Like
Share

revolting
Alcoholic
revolting
Alcoholic
Joined: 27 Sep 2013, 08:01 AM

27 Jan 2015, 09:16 PM #1966

Pawer: On another note, would it be reasonable to expect this new release to eclipse 13.0820 for multiplayer?

Jigebren: I don't really think so, at least not yet. We're precisely looking whether there's still any chance to make this code more stable for multiplayers, and if we can't get some results there'll be another release.
If you are able to combine the multiplayer method "split-scrren" with the method "Internet" or "LAN"I think you could be able to improve a lot the multiplayer experience, since you would be able to make a 12 racers game with just 3 computers involved :)
AKA geceb
Quote
Like
Share

jhs
Sober
jhs
Sober
Joined: 17 Nov 2014, 08:34 PM

28 Jan 2015, 12:08 PM #1967

Good stuff :) a15 :)
Quote
Like
Share

revolting
Alcoholic
revolting
Alcoholic
Joined: 27 Sep 2013, 08:01 AM

30 Jan 2015, 12:08 AM #1968

rv1.2a15.0125 has been causing my computer to reboot, playing GR and battletag racing mode, while with the 13 it doesn't cause that issue, thanks in advance and let me know if I can help you whit something else also I use the xp home edition 32bit

Found another bug watching a demo I saw in the AI a car that was upside down, so it flipped itself but before starting to accelerate it placed the oil it had so the oil trapped the same car that had it, so I think it would be a good improvement, if a car is allowed to drop the oil only when it is in movement and in the correct AI nodes :)
AKA geceb
Quote
Like
Share

ThugsRook
Alcoholic
ThugsRook
Alcoholic
Joined: 28 Sep 2014, 05:50 PM

30 Jan 2015, 02:30 AM #1969

15.0125 has lockup issues.

hardlocks the screen randomly, music is still playing, need to CAD to close it down.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

30 Jan 2015, 04:41 PM #1970

ThugsRook @ Jan 30 2015, 08:00 AM wrote: 15.0125 has lockup issues.

hardlocks the screen randomly, music is still playing, need to CAD to close it down.
Yes, confirmed there is a lockup issue in the current alpha. There should be a fixed release quite soon, thanks for the report.
revolting wrote:rv1.2a15.0125 has been causing my computer to reboot, playing GR and battletag racing mode, while with the 13 it doesn't cause that issue, thanks in advance and let me know if I can help you whit something else also I use the xp home edition 32bit
Maybe it's related to the lockup issue. We'll see if it still happens with the next alpha.
revolting wrote:Found another bug watching a demo I saw in the AI a car that was upside down, so it flipped itself but before starting to accelerate it placed the oil it had so the oil trapped the same car that had it, so I think it would be a good improvement, if a car is allowed to drop the oil only when it is in movement and in the correct AI nodes
Yep, we're not going to be working on the AI for now but that's something we should improve in the future.
Quote
Like
Share

Phantom
100% Proofer
Phantom
100% Proofer
Joined: 21 Mar 2011, 04:01 PM

31 Jan 2015, 02:17 PM #1971

Readme wrote:- Reverted back the new Time Trial file system


I finally got time to put my hands on this and let me tell you this is a celebration. I've noticed you made some tweaks here and there to create a newer time trial system, different from 0820 but this time better than it. I've tested it quite deeply and I have no complaints about it. :)

As a resume, I can say that this is currently the best time trial system ever because:
• It recognises times by their Level name (Toys in the Hood 1), not folder name (NHood1).
• Files are distributed in Folders, not in a single folder. No more suffixes!!! Thanks!!!
• It is compatible with times made on old versions, including the 0820. (users just have to rename NHood1.laplocal to Toys in the Hood 1.laplocal and it will work, I've tried it).
• It brings a great equilbrium between Global function and Per-Ratings function because it doesn't merge times when choosing the Global function. I've checked myself and I can confirm this.
• It doesn't modify the Ghost from each rating when beated by a higher rating (which is excellent because I'd like to keep the ghosts from every rating separated).

Before moving on, could you explain me some technical things I couldn't figure out yet:
1. I've noticed that Re-Volt automatically created a .LapLocal and .Times file inside the 5 Rating folders the first time I used it, even if I only used a Rookie car on Hood1/Normal mode.

2. I've also noticed that everytime I use Time Trial mode, all the files (.laplocal and .times) in my Times folder are modified according to what their file properties says (Last modified). It seems some modification is injected in them but it's not visible in the ghost or in the .times. What is this?

1 mini-suggestion:
Once in Time Trial mode, when you're in a race and press Esc, Best Times, you're not able to switch view in order to look at the other rating's times if you press Enter. You are able to do so from the Frontend - Best times window by pressing Enter but not when you entered in a track.
I'd desire to be able to check the times made with the other ratings without going back to Frontend. And also the ability to enable / disable the ghost car without going to Frontend.
We don't stop playing because we get older, we get older because we stop playing.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

1 Feb 2015, 05:12 AM #1972

Re-Volt v1.2 has been updated.
This should fix the lockup issue that was reported in the last release.
We've also quickly added support for load / save replay which was previously accessible only in dev mode. The "Load Replay" option is only visible when a replay was already saved (i.e., when a Replay.rpl file is present in the re-volt folder). The "Save Replay" option is only visible in game modes that support it.

Download the new Alpha release 15.0131 here (readme).


~ Huki & jigebren
Quote
Like
Share

Phantom
100% Proofer
Phantom
100% Proofer
Joined: 21 Mar 2011, 04:01 PM

1 Feb 2015, 06:36 AM #1973

Thanks for the new update. :)

After installing re-volt on a few computers I remembered a few important things I must tell you.

Eliminate the need to open the game offline once before launching it online.
Since you 2 haven't played online in a while I must explain things:
This problem started when the Profiles feature was introduced. Currently launching the game directly online via RV House or GameRanger before creating a profile offline implies the creation of a temporary profile with default settings. If the user configures screen resolution, keyboard, etc. on this temporary profile his settings disappear when the game ends and when he wants to race online again, he has to configure everything again. His previous settings are deleted only because he hadn't launched the game offline before. It seems that the multiplayer lobby mode is able to read already existing profiles but not save/write new profiles.

I usually have to indicate the new players that in order to fix this issue they have to run the game offline once, create their profile, configure their settings and then it will save. But I can't be indicating how to fix this error to everybody, they can't imagine this on their own. You must understand that online players do not desire to launch the game offline first. This is why even veteran players frequently have problems updating to 1.2 because it's not our natural behaviour to run te game offline before. For us the multiplayer interface is the only thing that matters.

Therefore, I suggest allowing the creation of the definite profile also when first launched via lobby mode instead of a temporary profile in case the user hasn't launched offline before.


The Patch Updater doesn't properly detect revolt.exe in the folder chosen by the user.
The 1st time I suggested the idea of adding a detection feature was because people got problems with the updater very often by installing the Patch on a wrong folder by mistake and my idea was to make the Patch able to detect if revolt.exe is present or not to definitely fix this issue.

Well, a few patches ago you added a feature where the Patch gives the message "Invalid path" when the default folder "C:\Program Files (x86)\Acclaim Entertainment\Re-Volt" is not created in the computer (that's my guess of what it checks). That feature is okay, very nice indeed, but here's the issue: It may check if the folder is created or not but I do know that it doesn't detect if revolt.exe is present or not. It continues the installation even when the user chooses a folder where the game is not installed, even with any random folder from the computer.

The following is a reproduction of the typical problem that my friends have when updating Re-Volt. I've tested and it's very easy to end up messing the update process, like this:
Step 1 - The user runs the patch installer. Since he hadn't opened re-volt offline first, the setup offers him to install it on the default folder "C:\Program Files (x86)\Acclaim Entertainment\Re-Volt". Since his actual Re-Volt folder is in Deskop\Games\Re-Volt (just for this example), the setup gives the error "Invalid path".
Step 2 - Following this message, the user now clicks on the little button "Browse" (thanks mum for paying the English classes) and chooses a different folder.
Step 3 - Ups! By mistake he selects the folder Games instead of selecting the folder Re-Volt. Guess what my friends, the installation goes on and the setup says "Setup completed successfully".
It even does on any random folder from the computer. I've also tried it on C:\Program Files (x86) and it also let it go on.

Conclusion, something should be done to prevent this and my propositions are:
Best option: Make the Patch able to properly detect if revolt.exe is inside the folder that was manually chosen by the user and deny installation if revolt.exe is not present.
Alternative: If the previous is not your in your possibilities, make something like most cracks of other games and programs do. A typical .exe file that must be placed inside the program folder and after double-clicking it, it checks the presence of the target file in that exact folder in order to proceed with the update only if the target files were found in that folder.

You must understand that it's not in the player's wish to understand or learn technical things to simply update their game. Most people don't know exactly where their game is installed on their computer, they expect the updater to find it.


The Patch Updater needs to offer Setup in more languages at startup, like most updaters.
My people don't understand what the Setup says and would desire to understand the messages. We're an international community and language sometimes blocks users from doing simple things. Could I translate the Patch Installer to my language? I can send you the strings if you tell me the messages I should translate. It's only a few buttons, descriptions and error messages.


The Setup should create a shortuct in the desktop when the correct Installation finished.
Can you make it so that the 1.2 Updater creates a shortcut to the current Re-Volt installation that was successfully updated? I noticed you removed this funcion but the creation of a shortcut after patching is something good. If you get to fix the revolt.exe detection, there won't be problems with creating a shortcut.
We don't stop playing because we get older, we get older because we stop playing.
Quote
Like
Share

nevermind
Alcoholic
nevermind
Alcoholic
Joined: 22 Jun 2014, 11:32 AM

1 Feb 2015, 04:51 PM #1974

Thank you for keeping RV development!

I found out that you can restart a race from a loaded replay (this applies both for the latest alpha and the alphas which featured it in dev mode). I know that the replay loading feature will be upgraded, but I do not want this to be forgotten.

Besides, if you try to create a replay from a Championship game, the game freezes (the camera is still rotating but no menu is open and you can do nothing) and you get 8 stopped cars when you try to run the replay.

Now that this project is quite active, I will report a minor two-year-old bug (as it is not new, a thread will be opened for it) and post a few suggestions.
Known as Jaenero in RV House
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

1 Feb 2015, 07:25 PM #1975

nevermind @ Feb 1 2015, 10:21 PM wrote: Thank you for keeping RV development!

I found out that you can restart a race from a loaded replay (this applies both for the latest alpha and the alphas which featured it in dev mode). I know that the replay loading feature will be upgraded, but I do not want this to be forgotten.

Now that this project is quite active, I will report a minor two-year-old bug (as it is not new, a thread will be opened for it) and post a few suggestions.
Thanks, all reports are welcome. We'll however prefer to add further fixes only in RVGL, but they may be backported to old 1.2 when / if we find the time.

And yes, restarting race from loaded replay is still supported.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 04:01 PM

1 Feb 2015, 08:51 PM #1976

Phantom @ Jan 31 2015, 07:47 PM wrote:Before moving on, could you explain me some technical things I couldn't figure out yet:
1. I've noticed that Re-Volt automatically created a .LapLocal and .Times file inside the 5 Rating folders the first time I used it, even if I only used a Rookie car on Hood1/Normal mode.

2. I've also noticed that everytime I use Time Trial mode, all the files (.laplocal and .times) in my Times folder are modified according to what their file properties says (Last modified). It seems some modification is injected in them but it's not visible in the ghost or in the .times. What is this?

1 mini-suggestion:
Once in Time Trial mode, when you're in a race and press Esc, Best Times, you're not able to switch view in order to look at the other rating's times if you press Enter. You are able to do so from the Frontend - Best times window by pressing Enter but not when you entered in a track.
I'd desire to be able to check the times made with the other ratings without going back to Frontend. And also the ability to enable / disable the ghost car without going to Frontend.
As part of the internal rewrite, all the rating files are loaded and saved together. It's safer this way and also clean. But no modification is injected, the unmodified files are simply loaded and re-saved as is. Of course, an eventual improvement would be to re-save only those files that have really been modified. And ok about the suggestion.
Phantom wrote:Eliminate the need to open the game offline once before launching it online.
Since you 2 haven't played online in a while I must explain things:
This problem started when the Profiles feature was introduced. Currently launching the game directly online via RV House or GameRanger before creating a profile offline implies the creation of a temporary profile with default settings. If the user configures screen resolution, keyboard, etc. on this temporary profile his settings disappear when the game ends and when he wants to race online again, he has to configure everything again. His previous settings are deleted only because he hadn't launched the game offline before. It seems that the multiplayer lobby mode is able to read already existing profiles but not save/write new profiles.
That's not true.. what is shown when launched in lobby mode is identical to when re-volt is started offline: the Create Profile screen is shown if there are no existing profiles, and the Select Profile menu is shown if there are existing profiles. Even if for some reason these screens are not shown, you will still see the Select Profile menu option in the Lobby main menu (under Options and above Quit IIRC). So I'm just confused, what menu are you getting when you are launched from lobby?
Is GameRanger or RVHouse passing any specific command lines to re-volt? (in RVHouse you can check that in the settings).
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

2 Feb 2015, 03:40 AM #1977

GameRanger only passes -sli (comes from 1.10)
RVH is customizable but by default it doesnt pass anything but 1.2 -netcomp cmdline (if needed) directplay needs the guid parameter for looby btw, so thats always passed.

Huki: also, why revolt is not UAC compliant yet? (should have been because of hell of issues with that) Will you put registry thing back when a "final" version is released? what about shipping an exe that uses registry settings (with autosave) ?
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

revolting
Alcoholic
revolting
Alcoholic
Joined: 27 Sep 2013, 08:01 AM

2 Feb 2015, 06:54 AM #1978

Excellent hot-fix huki, I haven't gotten to crash the game, at least not after It loaded the frontend on windows 7 (haven't tried on xp yet), by the way the game is way more stable for me in windows 7 than xp , I mean  there is no tearing in the graphics also less lag, probably and issue related to my graphic's driver on windows xp, :)
now that I tried it on windows xp I got it crashed after demo mode, :), just once though, I haven't been able to reproduce the problem :)
AKA geceb
Quote
Like
Share

ElectricBee
Regular
Joined: 11 Sep 2013, 04:47 PM

2 Feb 2015, 06:48 PM #1979

How do you know this, Juest?
I occasionally make stuff at Re-Volt Live. Come and check it out some time.
Traitors deserve the monsters they make.

Join us on Discord!
Quote
Like
Share

nevermind
Alcoholic
nevermind
Alcoholic
Joined: 22 Jun 2014, 11:32 AM

2 Feb 2015, 07:39 PM #1980

Hm, Market Arena (level for Supermarket in Battle Tag) features no music for me (I get the music from Redbook feature). Is that normal, may I be missing any file, or is this a bug in Redbook feature?
Known as Jaenero in RV House
Quote
Like
Share

VaiDuX461
Methanolic
VaiDuX461
Methanolic
Joined: 2 Jul 2011, 04:02 PM

2 Feb 2015, 07:53 PM #1981

nevermind @ Feb 2 2015, 09:39 PM wrote:Market Arena features no music for me. Is that normal, may I be missing any file, or is this a bug in Redbook feature?
Level INF file does not contain 'REDBOOK' line, which is why you can't hear anything.
Not sure if it was intended by original developers or just forgot when they rushed the game for release. I go with second option, other battle arenas have REDBOOK music after all.
aka VaidX47, Vaid
--------------------
>[MediaFire Stuff]< | >[Steam Profile]<
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

2 Feb 2015, 08:24 PM #1982

ElectricBee @ Feb 2 2015, 03:48 PM wrote: How do you know this, Juest?
Because im geekier than you: also look that i came before you dude.
I do smarter investigations than you.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

}!{enR
Regular
}!{enR
Regular
Joined: 17 Nov 2012, 05:07 PM

3 Feb 2015, 07:07 AM #1983

Well, since you started talking about Redbook bugs, and the developers are quite active for now, here is a 100% bug of a Redbook:
I have a problem with the "REDBOOK 13" track. After about 2/3 of playback it starts to stutter, no matter if I'm using a real CD or an image of such. And all the next music tracks played are still stuttering until I restart a game.

I have to mention that when this track is played in an ordinary music player there is no such problem. It's really annoying...

I don't have a time to properly test which builds have this bug, but it's stably reproducable in a13.0820.
a.k.a. EvgenKo423
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

3 Feb 2015, 08:36 AM #1984

hmm, i recall having shutters on 1.1/1.0 and theye were playing fine on a music player

Still its a doubtful topic because it may be a problem at that given moment...
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

jhs
Sober
jhs
Sober
Joined: 17 Nov 2014, 08:34 PM

4 Feb 2015, 02:37 PM #1985

I have with new version one problem.

The game via the Internet doesn´t work. When i/or brother Start the game, second player click on Join game... -> searching games -> and nothing is found. Conversely, it works the same way.

We are using newest alpha15.0131. Before some days we used a14.0208 and Game via Internet worked properly (99% of game).

EDIT: We used a14.0306 ... no a14.0208
Quote
Like
Share

revolting
Alcoholic
revolting
Alcoholic
Joined: 27 Sep 2013, 08:01 AM

5 Feb 2015, 02:44 AM #1986

I have with new version one problem.

The game via the Internet doesn´t work. When i/or brother Start the game, second player click on Join game... -> searching games -> and nothing is found. Conversely, it works the same way.

We are using newest alpha15.0131. Before some days we used a14.0208 and Game via Internet worked properly (99% of game).
have you downgraded your version to confirm the bug in the latest build?
AKA geceb
Quote
Like
Share

ThugsRook
Alcoholic
ThugsRook
Alcoholic
Joined: 28 Sep 2014, 05:50 PM

5 Feb 2015, 02:58 AM #1987

note on REDBOOK:

redbook still has a few bugs when using OGG files, but those bugs arent there when using the MP3 files.

both sets of files are available on RVL. id suggest anyone having problems while using OGG switch to the MP3 files.

:)
Quote
Like
Share

jhs
Sober
jhs
Sober
Joined: 17 Nov 2014, 08:34 PM

5 Feb 2015, 12:53 PM #1988

revolting @ Feb 5 2015, 03:44 AM wrote: have you downgraded your version to confirm the bug in the latest build?
I find where is problem. My brother did not have permission play over the internet in firewall. Now it run well. ;) Sometimes when connecting to the game to show me INVALID_PARAMETERS (1 run from 10 ) ... :) great to play via internet well :)
Quote
Like
Share

Gotolei
Alcoholic
Gotolei
Alcoholic
Joined: 12 Mar 2014, 12:26 AM

7 Feb 2015, 05:44 AM #1989

Minor thing: sadist cheat doesn't work if RShift is assigned on game startup.

Not sure if it's a bug or not though..? Tvtime and makeitgood functions don't seem to care about existing keybinds, so it seems a bit strange.
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

7 Feb 2015, 05:33 PM #1990

Gotolei @ Feb 7 2015, 02:44 AM wrote: Minor thing: sadist cheat doesn't work if RShift is assigned on game startup.

Not sure if it's a bug or not though..? Tvtime and makeitgood functions don't seem to care about existing keybinds, so it seems a bit strange.
Default re-volt keys are the best ones, other keys aren't guaranteed since 1.00
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Gotolei
Alcoholic
Gotolei
Alcoholic
Joined: 12 Mar 2014, 12:26 AM

7 Feb 2015, 09:52 PM #1991

For when someone actually helpful comes around, I'm also having fun times with makeitgood.

If you restart a race in Edit Mode, it likes to spawn pickups even if they're disabled in the options.
As if AI tuning wasn't already maddening enough :P
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

8 Feb 2015, 06:10 AM #1992

Gotolei @ Feb 7 2015, 06:52 PM wrote: For when someone actually helpful comes around, I'm also having fun times with makeitgood.

If you restart a race in Edit Mode, it likes to spawn pickups even if they're disabled in the options.
As if AI tuning wasn't already maddening enough :P
It does? because in FOB mode for example it renders all pickups and objects unusable lol!
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

revolting
Alcoholic
revolting
Alcoholic
Joined: 27 Sep 2013, 08:01 AM

8 Feb 2015, 06:49 PM #1993

Abc @ Feb 8 2015, 07:10 AM wrote:
Gotolei @ Feb 7 2015, 06:52 PM wrote: For when someone actually helpful comes around, I'm also having fun times with makeitgood.

If you restart a race in Edit Mode, it likes to spawn pickups even if they're disabled in the options.
As if AI tuning wasn't already maddening enough :P
It does? because in FOB mode for example it renders all pickups and objects unusable lol!
hehe, It sounds like: "No weapon formed against you will have any success,"
AKA geceb
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

12 Mar 2015, 05:32 PM #1994

Abc @ 8 Feb 2015, 03:10 AM wrote:
Gotolei @ Feb 7 2015, 06:52 PM wrote: For when someone actually helpful comes around, I'm also having fun times with makeitgood.

If you restart a race in Edit Mode, it likes to spawn pickups even if they're disabled in the options.
As if AI tuning wasn't already maddening enough :P
It does? because in FOB mode for example it renders all pickups and objects unusable lol!
Side note: in any edit mode when the car crosses the lap finish line the first time the game initializes a lot of stuff like pickups and such, in time trial it starts the ghost for example
Also all stars do show up and picking them haves no effect.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

ThugsRook
Alcoholic
ThugsRook
Alcoholic
Joined: 28 Sep 2014, 05:50 PM

12 Mar 2015, 10:37 PM #1995

^
-dev mode has something of a memory leak that corrupts the data.
restarting revolt (even normal revolt) doesnt help, revolt reuses that same corrupt data, must reboot computer to fix that.

corrupt data = graphic bugs, smeared skymap, white hud graphics, visibox flashing, etc.

-dev mode is not very stable, never was.

dont try to save your work if it does that.
Quote
Like
Share

Kenny
Methanolic
Kenny
Methanolic
Joined: 1 Jun 2010, 04:18 PM

13 Mar 2015, 08:55 AM #1996

ThugsRook @ 12 Mar 2015, 11:37 PM wrote: -dev mode has something of a memory leak that corrupts the data.
I don't think you know what memory leaks are or how they affect the program...
Quote
Like
Share

Skarma
Everclear-Addict
Skarma
Everclear-Addict
Joined: 20 Jul 2004, 01:05 PM

13 Mar 2015, 11:42 AM #1997

ThugsRook @ 12 Mar 2015, 10:37 PM wrote: -dev mode is not very stable, never was.

dont try to save your work if it does that.
I've been making my cars in dev mode for ages now and I've never had a single issue whatsoever.
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 7 Apr 2009, 06:43 PM

13 Mar 2015, 12:45 PM #1998

thugs: You're wrong and actually its makeitgood itself NOT -dev you silly! (-dev is a 1.2 feature)

I absolutely think like Kenny.
(ThugsRook @ 12 Mar 2015 @ 11:37 PM) wrote:-dev mode has something of a memory leak that corrupts the data.
I don't think you know what memory leaks are or how they affect the program..
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

mmudshark
Regular
Joined: 4 Apr 2011, 03:04 AM

25 Mar 2015, 04:17 AM #1999

Several of us have been using the 15.0131 version for online racing for well over a month now and the gameplay for the most part has been very good.
However I do have a few minor issues.

- The radar does not work as well as it does in other versions. I understand there are times when there are poor connections between racers but this happens far more often when using this version.
Even at the start of races it is wrong at times, and the same after the race is over.

- The spectating mode is terrible when late joining. Most of the time the cars just show as standing still, but you can see them hit with rockets and other weapons when they're fired.
Spectating other racers if you finish early works most of the time as it should.

- My race will still freeze once in a while for a second or two. This does not happen very often but was not a problem with earlier versions.

Keep up the good work and thanks,

mmud
Quote
Like
Share

Cosmo_Kramer
Alcoholic
Joined: 15 Feb 2011, 12:35 PM

11 May 2015, 07:35 PM #2000

Yes mostly using this version online now ,i have a question though...Is there a way i can move
sound changes that u made in 325 to this version 0131 somehow...
Cause in 325 all of my sound problems were fixed :unsure:
Quote
Like
Share