Moderators: Huki, jigebren

[HELP|RVGL] Host refuses connections

MarvTheM
Alcoholic
MarvTheM
Alcoholic
Joined: 7:45 AM - Jun 12, 2010

7:54 PM - Apr 04, 2017 #1

I'm writing this in behalf of Monskiller.

Whenever he's trying to host, nobody can connect to him. On the client side, RVGL just opens an error window stating that the connection has been refused (not a timeout).

Port 2310 (UDP) is apparently correctly forwarded. We tried it with and without the firewall activated. No success. We're both using the same version (17.0327).

If the info helps: Both of his IPs are correctly displayed when hosting (top right corner).

I'm not aware of any more factors that could hinder a connection. Any clues what else to try?
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 6:43 PM - Apr 07, 2009

10:42 PM - Apr 04, 2017 #2

Is his NAT open?
Did you consider that the ISP is blocking the router?
Connection Refused means the peer is there but not the port.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

savePinball
Non Drinker
savePinball
Non Drinker
Joined: 8:29 AM - May 15, 2015

5:33 AM - Apr 08, 2017 #3

A̶m̶ ̶a̶l̶s̶o̶ ̶h̶a̶v̶i̶n̶g̶ ̶t̶h̶e̶ ̶s̶a̶m̶e̶ ̶p̶r̶o̶b̶l̶e̶m̶ ̶a̶s̶ ̶M̶o̶n̶s̶k̶i̶l̶l̶e̶r̶.̶ ̶"̶C̶o̶n̶n̶e̶c̶t̶i̶o̶n̶ ̶h̶a̶s̶ ̶b̶e̶e̶n̶ ̶r̶e̶f̶u̶s̶e̶d̶"̶ ̶ ̶H̶a̶v̶e̶ ̶c̶h̶a̶n̶g̶e̶d̶ ̶m̶y̶ ̶l̶o̶c̶a̶l̶ ̶i̶p̶ ̶a̶d̶d̶r̶e̶s̶s̶ ̶f̶r̶o̶m̶ ̶D̶y̶n̶a̶m̶i̶c̶ ̶t̶o̶ ̶S̶t̶a̶t̶i̶c̶ ̶a̶s̶ ̶w̶e̶l̶l̶ ̶a̶s̶ ̶P̶o̶r̶t̶ ̶F̶o̶r̶w̶a̶r̶d̶e̶d̶ ̶T̶C̶P̶ ̶2̶3̶0̶1̶,̶ ̶4̶7̶6̶2̶4̶ ̶a̶n̶d̶ ̶U̶D̶P̶ ̶2̶3̶0̶0̶ ̶-̶ ̶2̶4̶0̶0̶.̶ ̶P̶u̶t̶ ̶r̶e̶v̶o̶l̶t̶ ̶i̶n̶ ̶t̶h̶e̶ ̶w̶h̶i̶t̶e̶l̶i̶s̶t̶ ̶f̶o̶r̶ ̶f̶i̶r̶e̶w̶a̶l̶l̶.̶ ̶T̶e̶s̶t̶e̶d̶ ̶t̶h̶e̶ ̶p̶o̶r̶t̶ ̶w̶i̶t̶h̶ ̶a̶ ̶p̶o̶r̶t̶ ̶t̶e̶s̶t̶e̶r̶ ̶a̶n̶d̶ ̶t̶r̶i̶e̶d̶ ̶t̶o̶ ̶p̶l̶a̶y̶ ̶a̶ ̶g̶a̶m̶e̶ ̶w̶i̶t̶h̶o̶u̶t̶ ̶r̶v̶h̶o̶u̶s̶e̶ ̶o̶r̶ ̶G̶a̶m̶e̶r̶a̶n̶g̶e̶r̶ ̶b̶u̶t̶ ̶d̶i̶d̶ ̶n̶o̶t̶ ̶w̶o̶r̶k̶.̶ ̶ ̶ ̶I̶ ̶h̶a̶v̶e̶ ̶t̶h̶e̶ ̶r̶o̶u̶t̶e̶r̶ ̶H̶u̶a̶w̶e̶i̶ ̶H̶G̶6̶3̶0̶b̶ ̶i̶f̶ ̶t̶h̶a̶t̶ ̶h̶e̶l̶p̶s̶.̶

I've just realised that this is the wrong place to post as this is a separate issue plus its very close to breaking this rule Do not report more than one issue in the same topic. Open a new topic for each new bug report!
Also doesn't help that we are getting different error messages than Monskiller...
So i'll probably get around to making a new post soon.
I'm a dude who likes digging up old games from my childhood!
I also lurk around forums most of the time.

My profile picture of a Dot Matrix Display was taken by ElHeineken, is under this license and was not edited.
Quote
Like
Share

Abc
100% Proofer
Abc
100% Proofer
Joined: 6:43 PM - Apr 07, 2009

7:47 AM - Apr 08, 2017 #4

Please read better, those instructions are wrong, follow the microsoft kb article.
its both tcp and udp for 2300-2400 range. but rvgl does not use this. it's not your standard directplay game.
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Quote
Like
Share

Huki
... as a Newt
Huki
... as a Newt
Joined: 4:01 PM - Dec 30, 2006

3:11 PM - Apr 08, 2017 #5

What is the exact error message that clients get when they connect to him?

Could it be that he has an IPv6?
Quote
Like
Share