[Done] [RVGL?] Serious problem with Jimk's warehouse kit

Report issues with v1.2 here.

Moderators: Huki, jigebren

[Done] [RVGL?] Serious problem with Jimk's warehouse kit

Strix
Regular
Strix
Regular
Joined: 05 Jun 2011, 09:04

31 Dec 2015, 11:00 #1

Hi.

I don't know if this is a problem with RVGL or the PRM files of this kit, but with RVGL it seems the prm files don't have any collision or textures anymore, this happen not only with the kit itself but also for tracks made with it.

Plus, in Instances mode of MAKEITGOOD, insert an instance just crashes the game, I remember that in a 1.2 alpha patch (don't remember what patch exactly, some tests are required anyway), there were no problem with these track or with the kit.

I run with a Windows 10 PC with last RVGL patch (this one that fixes sounds problems).

And some links
JimK's kit : http://revoltzone.net/instances/8913/Ji ... ouse%20Kit
Some tracks in RVZ with this problem (there are more tracks like that I think, didn't tested all)
http://revoltzone.net/tracks/6906/Warehouse
http://revoltzone.net/tracks/3711/Warehouse%20World%201
http://revoltzone.net/tracks/4098/The%20Warehouse

Note that, the warehouse track by dave-o-rama don't have any issue : http://revoltzone.net/tracks/4142/Warehouse%20Assault
As well for Warehouse NM by RickyD : http://revoltzone.net/tracks/4143/warehouse%20NM
and Toy-Volt warehouse :http://revoltzone.net/tracks/4116/Toy-Volt%20Warehouse
(Because they assembled all the instances into something new i guess)

So i'm not an expert in track files itself, I hope someone knows this and can solve this issue :huh:

EDIT : the kit works perfectly in a Re-volt with the patch 1207 only
EDIT 2 : works correctly in RV 1.2 too (this one downloadable in RVR)


Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

31 Dec 2015, 18:42 #2

Thanks for the report, I think I've tracked down the bug. The problem was that RVGL refused to load prm files with a capitalized extension name, like "instance.PRM". I think this is also the cause for the other bug reported by SebR (about instances not loading in Rooftops).

I have uploaded a fixed build, can you try it and report back if all the problems are solved?
rvgl_prm_test.7z
Reply
Like

Strix
Regular
Strix
Regular
Joined: 05 Jun 2011, 09:04

31 Dec 2015, 19:47 #3

Thanks for the fixe Huki :)


With this, the kit works as expected, I cac place any instances without crash same thing for the tracks I linked. except for "The Warehouse" (http://revoltzone.net/tracks/4098/The%20Warehouse), it don't even work in 1.2 (this track itself have some troubles maybe).


Reply
Like

Abc
100% Proofer
Abc
100% Proofer
Joined: 07 Apr 2009, 18:43

01 Jan 2016, 06:01 #4

Hmm, warehouse works on 1.2 :blink:
Yes, I'm the ABC block and you can find me in Toy World 1 track! ;)
Reborn as Juest Zungo :P PS: I prefer chatting and i have Steam, Skype, Google and Microsoft account, just ask for it via PM or rarely find me in RVHouse. Also check out my interests.
Reply
Like

Huki
... as a Newt
Huki
... as a Newt
Joined: 30 Dec 2006, 16:01

01 Jan 2016, 11:29 #5

Strix @ 1 Jan 2016, 01:17 AM wrote: With this, the kit works as expected, I cac place any instances without crash same thing for the tracks I linked. except for "The Warehouse" (http://revoltzone.net/tracks/4098/The%20Warehouse), it don't even work in 1.2 (this track itself have some troubles maybe).
The linked track works for me in both 1.2 and rvgl (I tested the Windows version of both using Wine on Linux). Can you try deleting the track and installing it again? If it still doesn't work, let me know what exactly doesn't work.

Oh, and welcome back Strix (I saw your WIP thread in RVL). :)
Reply
Like

Strix
Regular
Strix
Regular
Joined: 05 Jun 2011, 09:04

01 Jan 2016, 12:35 #6

Thanks Huki !

I had this track for some years, I installed it before the rework of RVZT, maybe the files was a bit different than currently or I don't know. I re-installed it and works perfectly now.

I should have did this before, sorry :huh:


Reply
Like