Centralization problems in the forums

Moderators: N54 Volunteer Moderator, Network54 Employee

Centralization problems in the forums

Joined: May 17th, 2006, 1:37 pm

January 8th, 2010, 12:24 pm #1

- Nick and Steven, I sent you an e-mail. Please, take a look at our request.

We're using DTD because of Internet Explorer, but the N54 HTML code needs a repair.

<table width="100%"><tr><td><center><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table><table width="220" bgcolor="#3f3f3f"><tr><td bgcolor="#ff5500"><center><font face="georgia" color="#FFFF00" size="3"> == Messias-BH. == </font><b></b>
</td></tr></table><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table></center></td></tr></table></center>
Quote
Like
Share

Joined: April 25th, 2002, 12:58 am

January 8th, 2010, 5:14 pm #2

<p>OK, then I get complaints when I complain about this type of thing. 2 posts, on 2 different tech forums AND an e-mail to tech support, ALL about the same exact issue, which is most likely an error in your HTML anyway.</p><p>I visit and help maintain several Network54 forums and NONE of them are having this problem. That would tell me that it is something in your code that is causing the problem. If you post a link to the forum in question, the people you are asking for help might be able to help you.</p>



Ripper®


Network54 Forum Tech Tips
Swap and Tech Forums
Quote
Like
Share

Joined: May 17th, 2006, 1:37 pm

January 9th, 2010, 1:12 am #3

- Ok, no problem.

Such message is to warn them about the email. Nothing else.
Thank you.

<table width="100%"><tr><td><center><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table><table width="220" bgcolor="#3f3f3f"><tr><td bgcolor="#ff5500"><center><font face="georgia" color="#FFFF00" size="3"> == Messias-BH. == </font><b></b>
</td></tr></table><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table></center></td></tr></table></center>
Quote
Like
Share

Joined: May 17th, 2006, 1:37 pm

January 9th, 2010, 2:30 am #4

<p>OK, then I get complaints when I complain about this type of thing. 2 posts, on 2 different tech forums AND an e-mail to tech support, ALL about the same exact issue, which is most likely an error in your HTML anyway.</p><p>I visit and help maintain several Network54 forums and NONE of them are having this problem. That would tell me that it is something in your code that is causing the problem. If you post a link to the forum in question, the people you are asking for help might be able to help you.</p>



Ripper®


Network54 Forum Tech Tips
Swap and Tech Forums
Subject is: We found a bug in the N54 code.

The issue IS NOT in our code. We face the problem, I found it and N54 can fix it.
So anyone who set DTD in his forum will face the same issue when using IE browser.

The problem is the N54 code versus IE, not the DTD.

This "bug" is VISIBLE to anyone who look into N54 source code. And it is shown only under IE browser when you activate DTD (which is very important for us). Browsers other than IE can easily work around that but, unfortunately, the Internet Explorer is the most used browser over the world.

Thus, I ask N54 guys: Fix the code please.
All advanced forums will thank you.

<table width="100%"><tr><td><center><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table><table width="220" bgcolor="#3f3f3f"><tr><td bgcolor="#ff5500"><center><font face="georgia" color="#FFFF00" size="3"> == Messias-BH. == </font><b></b>
</td></tr></table><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table></center></td></tr></table></center>
Quote
Like
Share

Joined: April 25th, 2002, 12:58 am

January 10th, 2010, 5:20 am #5

as to what setting is causing this problem and why the document type is so important for an internet forum.



Ripper®


Network54 Forum Tech Tips
Swap and Tech Forums
Quote
Like
Share

Joined: May 17th, 2006, 1:37 pm

January 10th, 2010, 9:21 am #6

I can't be sure if I'm allowed to publish the bug. This is why I sent that e-mail.
But you keep on asking. Now I feel I said too much here. Maybe they can respond better.

When any forum use the CSS rules to manage its appearence, the Document type is important because the IE browser demands it. Nothing else.
If Microsoft would agree to at least make the IE browser CSS/W3C fully compatible, we wouldn't need a DTD.

IE parser becomes sensible to the bug just when DTD is active. If N54 fix the HTML everything will be ok, this way everyone win. End users won't notice any change.
And the solution is very very simple.

<table width="100%"><tr><td><center><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table><table width="220" bgcolor="#3f3f3f"><tr><td bgcolor="#ff5500"><center><font face="georgia" color="#FFFF00" size="3"> == Messias-BH. == </font><b></b>
</td></tr></table><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table></center></td></tr></table></center>
Quote
Like
Share

Joined: April 25th, 2002, 12:58 am

January 11th, 2010, 5:46 am #7

I use CSS for my forums and it does not create the errors you mention. My Doctype is set at HTML 4.0. I have also tried setting it to HTML 5.0 as well as "None" and still did not see a style problem, which is why I asked what setting you were using.



Ripper®


Network54 Forum Tech Tips
Swap and Tech Forums
Quote
Like
Share

Joined: May 17th, 2006, 1:37 pm

January 12th, 2010, 9:48 pm #8

<p>OK, then I get complaints when I complain about this type of thing. 2 posts, on 2 different tech forums AND an e-mail to tech support, ALL about the same exact issue, which is most likely an error in your HTML anyway.</p><p>I visit and help maintain several Network54 forums and NONE of them are having this problem. That would tell me that it is something in your code that is causing the problem. If you post a link to the forum in question, the people you are asking for help might be able to help you.</p>



Ripper®


Network54 Forum Tech Tips
Swap and Tech Forums
Used settings are the N54 standard. This follows the same settings we've used in our forums: /599701

Consider this sample we got from one of them:



<table width="100%"><tr><td><center><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table><table width="220" bgcolor="#3f3f3f"><tr><td bgcolor="#ff5500"><center><font face="georgia" color="#FFFF00" size="3"> == Messias-BH. == </font><b></b>
</td></tr></table><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table></center></td></tr></table></center>
Quote
Like
Share

Joined: April 25th, 2002, 12:58 am

January 12th, 2010, 10:22 pm #9

<p>and, I guess, Opera, uses a different set of CSS rules than any other browser. To be honest, it is a pain in the you-know-what to makes websites compatible with IE 8. I had to rewrite entire pages because they wouldn't look right in IE 8. I hate it. I also think they took away things that worked and replaced them with things that don't work, but that's another story for another day.</p><p>I found that if you want different table cells to have different style formatting, in IE 8, you need to declare a class for the table cell, not just an "align" tag. If your standard TD class states that your text should be centered, setting any other attribute for your text will have no effect. To have your text align to the left, you have to place the non-centered text in a TD with a class that sets the text to align left. Putting < p align="left" > or even < td align="left" > won't do it for IE 8. I am not sure if this is your problem or not, but I suspect it might be.</p>



Ripper®


Network54 Forum Tech Tips
Swap and Tech Forums
Quote
Like
Share

Joined: May 17th, 2006, 1:37 pm

January 14th, 2010, 3:18 am #10

Hehehe... everything you said I tested and they didn't work utill I find the guilty. That's why I sent the solution in the email.

Is's a simple solution that will cost nothing to N54.

Hehehe ... everything you said I tried and they didn't work until I find the cause. That's why I sent the solution via email.

It is a simple solution that will cost nothing to N54.
In addition, the solution fixes an (or this) old bug in the code.

I just can't understand why it is taking so long.

<table width="100%"><tr><td><center><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table><table width="220" bgcolor="#3f3f3f"><tr><td bgcolor="#ff5500"><center><font face="georgia" color="#FFFF00" size="3"> == Messias-BH. == </font><b></b>
</td></tr></table><table width="180" bgcolor="#5f5f5f"><tr><td bgcolor="#00ddff"></td></tr></table></center></td></tr></table></center>
Quote
Like
Share


Confirmation of reply: