Question about hormones after failed DE (chemical)

Question about hormones after failed DE (chemical)

Violet
Violet

June 18th, 2012, 12:39 am #1

Hi
I got my period on 5/26 after a chemical. I felt like I ovulated around day 8 (early for me). I don't have my period and hpt says -.
I do have very tender breasts and feel pg. It feels like i have a lot of progesterone in my body. clearly I am not pg so now I am concerned my hormones are out of whack. Has anyone experienced this? I want to call my RE however I know they will tell me to wait it out.
Thanks
Violet
Quote
Share

smrc
smrc

June 18th, 2012, 2:31 am #2

I'm very sorry for your chemical.

I had a failed DE/early chemical in January of this year. My RE said it would take at least 1-2 cycles to get my cycles back to normal. I ended up having a relatively "normal" cycle right away, but I do think the drugs remain in your system for at least a month or two, which could account for why you're having different/strong symptoms.

If AF does not come soon, would you consider going in for a beta, just to double check? It may be worth having some b/w done just to check where your levels are.

Hang in there and, FWIW, I TTC'd with my OE during those first few months after the chem, since you do hear that you can be more fertile during that time.

SMRC
Quote
Share

Violet
Violet

June 20th, 2012, 2:54 pm #3

I appreciate your help with this. I am actually going to see my RE today and we'll get some bw done to see where I am.

How are you doing?
Violet
Quote
Share