Joined: March 23rd, 2004, 11:14 am

May 8th, 2018, 9:21 am #31

Thank you for the reply,
Well, maybe it used to have a plastic one that had tangs and went on the front ring gear hub? Perhaps the last person to work on it did not clean it up, that would match the rest of the quality of work.

I saw a picture on the net of a forward clutch assembly apart and the washer in the photo was plastic with looked like 3 tangs.

Thanks,
Scooter

I forgot to mention I think the forward piston was not working proper because it had a round inner oring instead of a square one like the others. May have not fit right and was harder.
You are likely correct on the melted plastic. some do have a plastic washer between the hub and fwd drum. Replacements I have bought are metal.

The centre seal in the forward drum is meant to be a round section o'ring.

Be sure during assembly to test each sealing ring one at a time for adequate drag on install
Quote
Like
Share

Joined: February 20th, 2018, 1:36 am

May 8th, 2018, 10:57 am #32

Thank you for the reply,
My current washer is metal.

I am sure glad you mention the center seal is supposed to be round. I have not made it yet to compare and check new seals, but will take your advice to check each one. I still need to inspect the valve assembly and then I will clean parts.

Thank you,
Scooter
Quote
Like
Share

Joined: February 20th, 2018, 1:36 am

May 8th, 2018, 11:01 am #33

Also need to be aware there are two different depth forward drums in that pocket where the bearing sits . Early is .330" , later is .405".
You must have the correct fwd ring gear hub to match the drum.

I just mention since the endfloat is way out. It is prob due to the missing washer/bearing but something to be aware of
Thank you for the reply,
I will check the depth. I had to buy a new bearing assembly since mine is missing the outer race. When I put that in, I will put the ring gear hub in to make sure it looks like it is in the right place.

Thank you,
Scooter
Quote
Like
Share

Joined: February 20th, 2018, 1:36 am

May 9th, 2018, 3:23 am #34

I started installing new bushings and see the pump housing bushing has a notch.  I lined it up with a hole behind the seal, but I see pictures of them installed with the notch facing the rear and left of center. Is that correct? 

Also see the rear stator support bushing has a notch, but do not see what that is supposed to line up with.  Can you explain which way it goes?
Please let me know.
Thank you,
Scooter
Quote
Like
Share