58 single range no upshift to 3rd

58 single range no upshift to 3rd

tom cassidy
tom cassidy

March 4th, 2011, 6:07 pm #1

After my last post about trying to find why the trans had a buzzing sound,I did get that resolved,more like it took care of itself. Must have been air that worked its way out.
Now I am testing trans with wheels off ground. When running up rpm in drive,it won't upshift to 3rd. The manual linkage is adjusted correct. I also tried to change linkage length so it would upshift early,but no change.
Trans has been recently rebuilt. Any suggestions?
Quote
Share

truck doctor
truck doctor

March 4th, 2011, 10:37 pm #2

you may want to check the vac modulator if you have a vac pump hook it up and put some vac on it for it to up shift.
Quote
Share

Joined: November 18th, 2004, 4:20 am

March 4th, 2011, 11:31 pm #3

After my last post about trying to find why the trans had a buzzing sound,I did get that resolved,more like it took care of itself. Must have been air that worked its way out.
Now I am testing trans with wheels off ground. When running up rpm in drive,it won't upshift to 3rd. The manual linkage is adjusted correct. I also tried to change linkage length so it would upshift early,but no change.
Trans has been recently rebuilt. Any suggestions?
If the buzzing is gone that could mean there was too much TV pressure.

Disconnect the TV rod at the transmission and leave it off.
See if there is an upshift now.

If not the governor could be sticking.

There is no modulator on this transmission.
Quote
Like
Share

truck doctor
truck doctor

March 5th, 2011, 12:46 am #4

thought is was a mid case
Quote
Share

Kevink1955
Kevink1955

March 5th, 2011, 4:05 am #5

Does that trans start out in first, I am not sure what was used in 58 but in 56 they did not start out in first unless you put the shifter in low or put the accelerator all the way to the floor.

What I am geting at is if you only feel 1 shift in drive it may be because it was designed to start in second then upshift to 3rd so you would only feel 1 shift.

If that is the case, put it in low and run it to 5mph then move the shifter to drive it should shift to second. accelerate a little more and it should shift to third.
Quote
Share

***no login***
***no login***

March 5th, 2011, 5:16 am #6

I did disconnect the TV rod and tested it that way. I did get it to downshift to 1st when it was pushed all the way down. So Stuart may be right that the governor is sticking. I'll pull the governor tomorrow and inspect. At least that's an easy task. Thanx all! Tom
Quote
Share

tom cassidy
tom cassidy

March 5th, 2011, 1:21 pm #7

After my last post about trying to find why the trans had a buzzing sound,I did get that resolved,more like it took care of itself. Must have been air that worked its way out.
Now I am testing trans with wheels off ground. When running up rpm in drive,it won't upshift to 3rd. The manual linkage is adjusted correct. I also tried to change linkage length so it would upshift early,but no change.
Trans has been recently rebuilt. Any suggestions?
I removed the governor and checked it. It was moving freely,not sticking. What would be the next move,remove pan and valve body?
Quote
Share

Joined: November 18th, 2004, 4:20 am

March 5th, 2011, 8:33 pm #8

Does that trans start out in first, I am not sure what was used in 58 but in 56 they did not start out in first unless you put the shifter in low or put the accelerator all the way to the floor.

What I am geting at is if you only feel 1 shift in drive it may be because it was designed to start in second then upshift to 3rd so you would only feel 1 shift.

If that is the case, put it in low and run it to 5mph then move the shifter to drive it should shift to second. accelerate a little more and it should shift to third.
Being a single range transmission in D position it will start out in second then shift into high.
Quote
Like
Share

Joined: November 18th, 2004, 4:20 am

March 5th, 2011, 8:36 pm #9

I removed the governor and checked it. It was moving freely,not sticking. What would be the next move,remove pan and valve body?
If the governor is free, ok.

Is the governor assembly installed correctly?
Like bassackwards?


If that is correct then VB is the next step.

Does the TV arm have any spring affect?

The inner TV valve could be hung up,
Quote
Like
Share

kevink1955
kevink1955

March 6th, 2011, 12:34 am #10

When it's in drive does it shift at all or just stay in 1 gear?
Quote
Share