Sea Fury

A place to request and discuss new types or showcase models.

Sea Fury

koenig
Officer Cadet
koenig
Officer Cadet
Joined: May 13th, 2014, 3:54 pm

November 2nd, 2016, 4:28 pm #1

Hi,
every time I try to fly the Sea Fury my engine departes and the plane is spinning like hell.
It even happens when on the ground!
Afterwards the engine plus prop is missing.
I'm observing the limitations so I really don't know how to operate the Fury safely!
Any solutions?

Best regards
Andreas
Quote
Like
Share

SkippyBing
Rear Admiral
SkippyBing
Rear Admiral
Joined: November 19th, 2008, 10:59 pm

November 2nd, 2016, 10:58 pm #2

Hi Andreas,

I think from memory this is something to do with FSUIPC conflicting with the engine gauge.

If you check this thread it may solve your problem

http://z13.invisionfree.com/Flying_Station...p?showtopic=249

Let me know how that goes, if not I should be able to have a look this weekend.

Skippy
Quote
Like
Share

koenig
Officer Cadet
koenig
Officer Cadet
Joined: May 13th, 2014, 3:54 pm

February 26th, 2018, 1:42 pm #3

Hi Skippy,
found the solution :
I installed new sound files for my Sea Fury which are obviously the reason for the "unreliable" engine.
Reinstalled your sound files and the problem simply disappeared.
Are there any updates for the Fury?

Thank you very much for your help!

Best regards

Andreas
SkippyBing wrote:
November 2nd, 2016, 10:58 pm
Hi Andreas,

I think from memory this is something to do with FSUIPC conflicting with the engine gauge.

If you check this thread it may solve your problem

http://z13.invisionfree.com/Flying_Stat ... wtopic=249

Let me know how that goes, if not I should be able to have a look this weekend.

Skippy
Quote
Like
Share