Essbase connection error through Provider Services

Essbase connection error through Provider Services

SD
SD

December 8th, 2011, 4:41 pm #1

Hello,

I'd be glad to discuss with you this topic. We have a program that uses JAPI to connect to Essbase via Provider Services (APS)

On some environment, we have a strange error : if you try to run the program 10 times, 8 times there is the following Error in Essbase.log, and the program can not work properly

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Error(1042012)
Network error [32]: Cannot Send Data

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///43/Error(1051021)
You have been logged out due to inactivity or explicitly by the administrator.

Does any of you have encountered this problem ? I tried to change APS essbase.properties parameters, to increase netdelay / netretrycount and these kind of parameters, but with no luck. Even with high properties, the error is thrown almost immediatly after the program is launched.

Having a look in details to Essbase.log below shows that a login occur, but then the error is thrown. Essbase work perfectly when connecting using maxl or Essbase Addin. But if we connect from Web Analysis (which uses JAPI / APS), the same error occur.

Any help greatly appreciated
Sebastien

ESSBASE.LOG DETAILS

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Info(1051164)
Received login request from [138.21.146.129]

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Info(1051187)
Logging in user [system] from [138.21.146.129]

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Info(1051035)
Last login on Thursday, December 08, 2011 5:28:02 PM

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Error(1042012)
Network error [32]: Cannot Send Data

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Warning(1051003)
Error 1042012 processing request [Login] - disconnecting

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///39/Error(1042012)
Network error [32]: Cannot Send Data

[Thu Dec 8 17:28:15 2011]Local/ESSBASE0///43/Error(1051021)
You have been logged out due to inactivity or explicitly by the administrator.
Reply
Share

Tim Tow
Tim Tow

December 8th, 2011, 5:03 pm #2


Briefly, what type of operations does your Java API application call against Essbase? Also, which operating system are you using for your client and your server?

Tim Tow
Oracle ACE Director
Applied OLAP, Inc
Reply
Share

SD
SD

December 9th, 2011, 9:01 am #3

Hello Tim,

The application does almost nothing, but check access through APS are working properly... Which is not the case :~)

# It connects to Essbase server
this.olapServer = (IEssOlapServer)dom.getOlapServer(essBean.getOlapServerName());
this.olapServer.connect();

# Then, we try to get An application object from the Essbase server
this.application = this.olapServer.getApplication(essBean.getApplicationName());

The problem occurs exaclty here : olapServer.getApplication (IEssOlapServer), where the exception is thrown.

We run Essbase & APS on HP-UX (11.23) Itanium 64 server, 8 Gb of RAM, 4 CPU

Best Regards,
Sebastien
Reply
Share

SD
SD

December 9th, 2011, 9:07 am #4

Briefly, what type of operations does your Java API application call against Essbase? Also, which operating system are you using for your client and your server?

Tim Tow
Oracle ACE Director
Applied OLAP, Inc
Some other interesting information :

When we try to run the program, using another Provider Services (running on another server), and connecting to the same Essbase server where we had the network error, it works fine. This means that there is a specific problem with the Provider services server that is used. But I'd like to find out what is this APS problem.

And to complete the previous response, the problem is the same running the java program directly on the problematic server, or on a remote Windows laptop...

Sebastien
Reply
Share


Confirmation of reply: