EIS - SQL drill through

EIS - SQL drill through

PD
PD

February 20th, 2013, 4:44 pm #1

So, we copied a model and it's metaoutline. We changed the new model to pull our store hierarchy from different table. we deleted the old dimension (from the old table) from the metaoutline, and brought in the same dim (but from the new table). We deleted the drill through report, and then re-created the outline and loaded the data in test.

Then re-created the drill through report. On testing the drill though it now no longer uses the store table in the SQL For example:

old sql

select * from data_table aa, store_table ab
where aa.store=ab.store
and ab.gen6 = 'example store name'

new sql
select * from data_table aa
where aa.store = 'example store name'

This is not the exact sql, but it illustrates the issue. Anyone know what is going on, and how to fix it?
Quote
Share

Joined: November 16th, 2003, 11:27 pm

February 20th, 2013, 7:57 pm #2

Check your joins in the OLAP model. See if anything is not set up properly there.
Quote
Like
Share

PD
PD

February 21st, 2013, 1:06 pm #3

It is a head scratcher. I literally had the two models open in two different windows side by side comparing every minute detail....nothing stood out. I am thinking of re-creating from a blank model and metaoutline and seeing if that "fixes" the problem.
Quote
Share

PD
PD

February 21st, 2013, 6:48 pm #4

Sorry folks, false alarm.

Our gen hierarchy in the metaoutline had some filter SQL logic on the level zero member....ugh, took me ages to figure it out.

On the one had I feel like I wasted two days, on the other I feel a little more sane.
Quote
Share


Confirmation of reply: